Hadoop Common
  1. Hadoop Common
  2. HADOOP-5161

Accepted sockets do not get placed in DataXceiverServer#childSockets

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.19.0
    • Fix Version/s: 0.19.1
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      DAtaXceiver#childSockets is a map that keeps track of all open sockets that are accepted by DataXceiverServer but no socket does get added to this map.

      1. childSockets1.patch
        0.7 kB
        Hairong Kuang

        Activity

        dhruba borthakur added a comment -

        In the 0.18 branch, there is a call to childSockets.put(s, s) in the constructor of DataXceiver. I guess it might have got removed when the re-org of source code happened. This could cause some unit tests to fail, especially those unit tests that create/delete multiple instances of datanode.

        Hairong Kuang added a comment -

        Thanks, Dhruba. Here is a patch that adds the line back.

        Hairong Kuang added a comment -

        Mark it to be fixed in 0.19.1 since this is a regression.

        dhruba borthakur added a comment -

        +1. code looks good.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12399488/childSockets1.patch
        against trunk revision 740532.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        -1 contrib tests. The patch failed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3800/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3800/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3800/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3800/console

        This message is automatically generated.

        Hairong Kuang added a comment -

        The failed core test case TestInjectionForSimulatedStorage seems to be caused by HADOOP-5192.

        Hairong Kuang added a comment -

        I've just committed this.

        The failed unit tests are not related to this fix and HADOOP-5192 may not be the sole cause of the failure.

        Hudson added a comment -

          People

          • Assignee:
            Hairong Kuang
            Reporter:
            Hairong Kuang
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development