Hadoop Common
  1. Hadoop Common
  2. HADOOP-4546

Minor fix in dfs to make hadoop work in AIX

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.18.0, 0.19.0
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      AIX

    • Hadoop Flags:
      Reviewed

      Description

      HDFS uses df command to get the disk space. The output format of df command is different in AIX compared to Linux and Solaris. Checking the OS type and then reading the df output as per the format will fix this issue and thus allows hadoop to be fully functional in AIX environment.

      1. dfs_aix_fix.patch
        2 kB
        Arun Venugopal
      2. TestDFVariations.java
        6 kB
        Bill Habermaas
      3. hadoop-4546.patch
        3 kB
        Bill Habermaas
      4. 4546-1.patch
        10 kB
        Chris Douglas
      5. 4546-2.patch
        6 kB
        Chris Douglas

        Activity

        Tom White made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Owen O'Malley made changes -
        Component/s dfs [ 12310710 ]
        Hudson added a comment -
        Allen Wittenauer added a comment - - edited

        [ignore me, i'm thinking of a different problem]

        Bill Habermaas added a comment -

        Thanks for clarifying the issues. This fix goes back to early november when 0.18 was the current release. It's a shame that this couldn't make it into the system back then. Anyway, thanks for your help. much appreciated.

        Chris Douglas added a comment -

        I don't see any reason why this can't be included in 0.18.4 as the original code that is patched has not been changed over the last few releases.

        That's not one of the criteria Hadoop uses to determine whether a patch should be backported. That the code is stable is an argument against backporting this for two reasons. First, there are no known issues with it and any changes may destabilize it, requiring more maintenance releases. Second, applying the patch isn't unduly burdensome, neither does it require any special build instruction, so interested parties can apply this themselves. Hadoop's release criteria are conservative, in part because most organizations want to backport some subset of later releases into stable branches.

        With few exceptions, the only patches that get pushed into older branches are those that fix behavior that was unintentionally and incompatibly broken in that branch or earlier. If it can be demonstrated that a previous version of Hadoop was compatible with AIX, then the patch can be pushed into previous releases, but lacking that it requires a special dispensation.

        Bill Habermaas added a comment -

        I just checked the repository and the patch has been committed to trunk. So that is why it didn't apply when resubmitted.

        Bill Habermaas added a comment -

        I see this still didn't get through Hudson again.
        For what it might be worth, I applied 4546-2.patch to 0.18.3 when I did all my unit testing on AIX (I don't have a Java6 running on my AIX).
        I don't see any reason why this can't be included in 0.18.4 as the original code that is patched has not been changed over the last few releases.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12400901/4546-2.patch
        against trunk revision 749318.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        -1 patch. The patch command could not apply the patch.

        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-vesta.apache.org/32/console

        This message is automatically generated.

        Chris Douglas made changes -
        Resolution Fixed [ 1 ]
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Chris Douglas added a comment -

        I'm reopening this issue to resubmit patch to hudson.. For some reason hudson didnt accept this patch..( possibly a jira issue)

        The issue has been resolved and the patch committed to the repository. I'm assuming this was accidental and part of a batch operation, but please accept my apologies if I misunderstand your purpose. I'm re-marking this as "resolved".

        I see this is noted as fixed on 0.21 - any way it can be applied to 0.18.4? It needs to be available for Java5 as well as Java6. AIX users are likely to need the Java5 version. Or will the patch get applied to the Java5 version?

        Unfortunately, it's not likely to be applied to any branch prior to 0.21 since this isn't a regression. If this worked on AIX for some previous, released version of Hadoop, then one could argue that the fix should be backported, but I don't think that's the case. Neither am I certain we're going to roll an 0.18.4 release, anyway. Does AIX not have a Java6 port?

        Giridharan Kesavan made changes -
        Status Reopened [ 4 ] Patch Available [ 10002 ]
        Giridharan Kesavan added a comment -

        resubmitting patch

        Giridharan Kesavan made changes -
        Resolution Fixed [ 1 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        Giridharan Kesavan added a comment -

        I'm reopening this issue to resubmit patch to hudson.. For some reason hudson didnt accept this patch..( possibly a jira issue)
        tnx!

        Bill Habermaas added a comment -

        Thanks for your help Chris. I see this is noted as fixed on 0.21 - any way it can be applied to 0.18.4? It needs to be available for Java5 as well as Java6. AIX users are likely to need the Java5 version. Or will the patch get applied to the Java5 version?

        Chris Douglas made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Fix Version/s 0.21.0 [ 12313563 ]
        Resolution Fixed [ 1 ]
        Chris Douglas added a comment -

        All the unit tests passed, save org.apache.hadoop.chukwa.datacollection.adaptor.filetailer.TestStartAtOffset, which is not related.

        I committed this. Thanks, Bill

        Chris Douglas added a comment -

        At this point we typically wait for Hudson to run its tests, but the queue is disabled for some reason, so I verified on my my machine:

             [exec] -1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 3 new or modified tests.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
             [exec] 
             [exec]     -1 release audit.  The applied patch generated 797 release audit warnings (more than the trunk's current 796 warnings).
        

        I've no idea why this generated a release audit warning. The diff mentions something in the docs, which shouldn't be affected by the patch. The new unit test has a license header... I think it's spurious.

        I'm running the unit tests now. All the core and HDFS tests have passed, so I expect this can go in today.

        Bill Habermaas added a comment -

        Chris: Ok, is there something I need to do for this to move along.

        Chris Douglas made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Chris Douglas added a comment -

        Patch 4546-2.patch has been applied and tested on AIX 6.1 and it works. I assume that is what you are asking.

        Yes, that's what I was asking. If Hudson is OK with this, I think it can be committed

        Bill Habermaas added a comment -

        Chris: Patch 4546-2.patch has been applied and tested on AIX 6.1 and it works. I assume that is what you are asking. I have also run the test-core unit tests as well with the expected good results.
        Can we give this another shot?

        Bill Habermaas added a comment -

        The patch and supplied unit test work on AIX 6.1. I have run the Hadoop unit tests against my patched version also. Prior to the patch about 60 tests fail, after the patch only 2 fail for unrelated reasons (and I have created jira entries for those). I noticed that the junit test failed because disk space changed between calls. What do you recommend be done to rework the test so this patch will pass all requirements?

        Chris Douglas made changes -
        Attachment 4546-2.patch [ 12400901 ]
        Chris Douglas added a comment -

        Does this work on AIX?

        Chris Douglas made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Chris Douglas added a comment -

        The unit test is likely to fail; one can't assume that disk space won't change between calls. A unit test validating the parsing would make more sense.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12400881/4546-1.patch
        against trunk revision 747332.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 3 new or modified tests.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3913/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3913/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3913/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3913/console

        This message is automatically generated.

        Chris Douglas made changes -
        Affects Version/s 0.19.0 [ 12313211 ]
        Original Estimate 24h [ 86400 ]
        Affects Version/s 0.18.0 [ 12312972 ]
        Affects Version/s 0.20.0 [ 12313438 ]
        Remaining Estimate 24h [ 86400 ]
        Chris Douglas made changes -
        Affects Version/s 0.19.0 [ 12313211 ]
        Status Open [ 1 ] Patch Available [ 10002 ]
        Affects Version/s 0.18.1 [ 12313357 ]
        Hadoop Flags [Reviewed]
        Affects Version/s 0.18.2 [ 12313424 ]
        Affects Version/s 0.20.0 [ 12313438 ]
        Chris Douglas made changes -
        Assignee Bill Habermaas [ bhabermaas ]
        Chris Douglas made changes -
        Attachment 4546-1.patch [ 12400881 ]
        Chris Douglas added a comment -

        Merged original patch and unit test.

             [exec] +1 overall.  
             [exec] 
             [exec]     +1 @author.  The patch does not contain any @author tags.
             [exec] 
             [exec]     +1 tests included.  The patch appears to include 3 new or modified tests.
             [exec] 
             [exec]     +1 javadoc.  The javadoc tool did not generate any warning messages.
             [exec] 
             [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler warnings.
             [exec] 
             [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
             [exec] 
             [exec]     +1 Eclipse classpath. The patch retains Eclipse classpath integrity.
             [exec] 
             [exec]     +1 release audit.  The applied patch does not increase the total number of release audit warnings.
        
        dhruba borthakur added a comment -

        @Chris: will appreciate it a lot if you can review this patch one more time. Thanks a bunch!

        Bill Habermaas made changes -
        Attachment TestDFVariations.java [ 12399356 ]
        Attachment hadoop-4546.patch [ 12399357 ]
        Bill Habermaas added a comment -

        The original patch author says he does not have an AIX system to finish this fix. I have made the suggested revision to the source, written a unit test, and tested the patch/unit test on AIX 6.1(in addition to running the normal ANT junit tests on that system). If I need to take further action to ensure this fix becomes permanently included in the system then please provide further guidance.

        Bill Habermaas made changes -
        Affects Version/s 0.18.2 [ 12313424 ]
        Affects Version/s 0.19.0 [ 12313211 ]
        Chris Douglas made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Chris Douglas added a comment -

        A minor comment about the patch: it would be nice if you can create a enum named DF.OSType that follows the pattern in src.core.org.apache.fs.FileUtil.HardLink.OSType. Then it will be elegant to add newer platform support for DF parsing in the future.

        +1 (and the unit test).

        So Hudson can apply the patch, would you mind generating it from the root? It should apply cleanly with patch -p0 < file

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12393233/dfs_aix_fix.patch
        against trunk revision 709609.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no tests are needed for this patch.

        -1 patch. The patch command could not apply the patch.

        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3522/console

        This message is automatically generated.

        dhruba borthakur added a comment -

        Hi Arun, your patch looks good. Would it be possible for you to write a unit test as Steve suggested? The details are explained in http://wiki.apache.org/hadoop/HowToContribute

        A minor comment about the patch: it would be nice if you can create a enum named DF.OSType that follows the pattern in src.core.org.apache.fs.FileUtil.HardLink.OSType. Then it will be elegant to add newer platform support for DF parsing in the future.

        Arun Venugopal added a comment -

        I am not sure how a patch should be created. I assume it would be a diff output. I have attached the diff output of the changes I have made to make it work on AIX. Hope this helps.

        Arun Venugopal made changes -
        Attachment dfs_aix_fix.patch [ 12393233 ]
        Arun Venugopal added a comment -

        svn diff output of DF.java

        Arun Venugopal made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        dhruba borthakur added a comment -

        It would be really nice if you could a submit a patch for this one. I am suspecting that the code changes will be concentrated in src/core/org/apache/hadoop/fs/DF.java. A syntax similar to src.core.org.apache.fs.FileUtil.HardLink can be followed.

        steve_l added a comment -

        although this will be hard to test on non AIX systems, if the parsing is decoupled from the execution, you could have junit tests that verify you can parse AIX output just by handing static strings of df output to the parser. this would keep coverage up and catch regressions early.

        Nigel Daley made changes -
        Field Original Value New Value
        Fix Version/s 0.18.1 [ 12313357 ]
        Arun Venugopal created issue -

          People

          • Assignee:
            Bill Habermaas
            Reporter:
            Arun Venugopal
          • Votes:
            3 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development