Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.19.0
    • Component/s: build
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      There are javadoc warnings caused by failmon:

        [javadoc] Loading source files for package org.apache.hadoop.contrib.failmon...
        [javadoc] Constructing Javadoc information...
        [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging"
        [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging.impl"
      
      1. failmonWarnings.patch
        1 kB
        dhruba borthakur

        Issue Links

          Activity

          Hudson added a comment -
          dhruba borthakur added a comment -

          I just committed this.

          Nigel Daley added a comment -

          +1 for this patch. Let's get it committed. I suspect the src/contrib/failmon/lib dir may have existed from a previous run.

          dhruba borthakur added a comment -

          I submitted this patch because it will help clear up test failures triggered by other Hudson patch test runs. Somebody shoudl manually remove src/contrib/failmon/lib directory from the workspace on which HadoopQA runs the tests.

          Tsz Wo Nicholas Sze added a comment -

          "ant javadoc" and "ant test-patch" results should be consistent. It should be the case that "ant test-patch" reports javadoc warnings if and only if "ant javadoc" reports javadoc warnings.

          dhruba borthakur added a comment -

          The attached patch file removes (precisely) those lines in the build.xml! I wonder why test-patch still fails....

          Nigel Daley added a comment -

          Here's the problem from the failmon buildl.xml:

              <mkdir dir="lib"/>
          
              <copy todir="lib">
                <fileset dir="${hadoop.root}/lib/"
                         includes="commons-logging-*, log4j*"/>
              </copy>
          
              <copy todir="lib">
                <fileset dir="${hadoop.root}/build/"
                         includes="hadoop-*"/>
              </copy>
          

          The first copy block is the reason for this issue I think.
          The second copy block is the reason for HADOOP-4021 I think.

          Nigel Daley added a comment -

          Dhruba, on a clean workspace, run
          ant tar

          You'll notice once this completes, src/contrib/failmon/lib exists with those files. It's simple to reproduce. It's not anything special that HadoopQA or test-patch.sh is doing.

          dhruba borthakur added a comment -

          i think the problem is that the script that HadoopQA runs src/test/bin/test-patch.sh creates and copies the following set of files into src/contrib/failmon/lib:

          ommons-logging-1.0.4.jar
          hadoop-PATCH-failmonWarnings.patch
          hadoop-PATCH-failmonWarnings.patch-examples.jar
          hadoop-PATCH-failmonWarnings.patch-test.jar log4j-1.2.15.jar
          commons-logging-api-1.0.4.jar
          hadoop-PATCH-failmonWarnings.patch-core.jar
          hadoop-PATCH-failmonWarnings.patch.tar.gz
          hadoop-PATCH-failmonWarnings.patch-tools.jar

          I do not knwop why it picks this directory to create these files. This is a problem only with the test-patch target. Nigel: can you pl advise on why the script copies it into this directory? Thanks.

          Nigel Daley added a comment -

          Dhruba, you can run test-patch yourself. Search for "test-patch" at http://wiki.apache.org/hadoop/HowToContribute to see how. This ant target runs the script in src/test/bin

          dhruba borthakur added a comment -

          I cannot run the test-patch target, it is setup to be run by HadoopQA. Maybe Nigel can help in shedding some light on the difference between the target the HadoopQA runs and "ant javadocs".

          Tsz Wo Nicholas Sze added a comment -

          Tested the following

          • "ant javadoc" on trunk: no warning
          • "ant test-patch" on trunk: 2 warnings
          • "ant javadoc" on trunk + Dhruba's patch: no warning
          • "ant test-patch" on trunk + Dhruba's patch: 2 warnings

          Seems there is some wrong on javadoc target or test-patch target.

          dhruba borthakur added a comment -

          Retriggerong HudsopnQA. I do not see these warnings with trunk itself. This patch is just a cleanup.

          dhruba borthakur added a comment -

          In my workspace, without the patch I see the two warnings from running "ant javadocs". With the patch, I do not see these two warnings. I am using jdk 1.6.0_07, could this be an issue?

          Nigel Daley added a comment -

          The patch didn't seem to fix the problem. I still see:

          [exec] [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging"
          [exec] [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging.impl"

          in the console log of this patch build:
          http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3084/console

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12388570/failmonWarnings.patch
          against trunk revision 687868.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no tests are needed for this patch.

          -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 findbugs. The patch does not introduce any new Findbugs warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed core unit tests.

          -1 contrib tests. The patch failed contrib unit tests.

          Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3084/testReport/
          Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3084/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
          Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3084/artifact/trunk/build/test/checkstyle-errors.html
          Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3084/console

          This message is automatically generated.

          Tsz Wo Nicholas Sze added a comment -

          +1 patch looks good.

          dhruba borthakur added a comment -

          Fix javadoc warnings.


            People

            • Assignee:
              dhruba borthakur
              Reporter:
              Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development