Hadoop Common
  1. Hadoop Common
  2. HADOOP-3949

javadoc warnings: Multiple sources of package comments found for package

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.19.0
    • Component/s: build, documentation
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Beginning from Hudson build #3046, there are javadoc warnings in trunk.
      See http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3046/artifact/trunk/current/patchJavadocWarnings.txt

        [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging"
        [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.codec"
        [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.codec.binary"
        [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging.impl"
      
      1. HADOOP-3949.patch
        0.4 kB
        Jerome Boulon
      2. svnCmde.sh
        0.6 kB
        Jerome Boulon

        Issue Links

          Activity

          Tsz Wo Nicholas Sze added a comment -

          The problem is due to trunk/.../contrib/chukwa. In trunk/.../chukwa/lib, there are jar files duplicated with trunk/lib.

          Jerome Boulon added a comment -

          Remove duplicate jar files

          Jerome Boulon added a comment -

          Modify classpath to include Hadoop libraries.

          Jerome Boulon added a comment -

          Apply the patch file to change Chukwa's classpath and execute the shell script to remove duplicate jar files

          Owen O'Malley added a comment -

          I just committed this. Thanks, Jerome!

          Amareshwari Sriramadasu added a comment -

          Commons logging warnings still exist on the trunk. The warnings:

            [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging"
            [javadoc] javadoc: warning - Multiple sources of package comments found for package "org.apache.commons.logging.impl"
          
          Tsz Wo Nicholas Sze added a comment -

          I think these warnings are new and they are caused by failmon. See HADOOP-3964

          Hudson added a comment -

            People

            • Assignee:
              Jerome Boulon
              Reporter:
              Tsz Wo Nicholas Sze
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development