Hadoop Common
  1. Hadoop Common
  2. HADOOP-3874

TestFileAppend2.testComplexAppend sometimes fails

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Later
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: test
    • Labels:
      None

      Description

      This failed while testing an unrelated change:

      http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2985/testReport/

        Issue Links

          Activity

          Doug Cutting created issue -
          Nigel Daley made changes -
          Field Original Value New Value
          Fix Version/s 0.19.0 [ 12313211 ]
          Component/s test [ 12311440 ]
          Tsz Wo Nicholas Sze made changes -
          Link This issue relates to HADOOP-2658 [ HADOOP-2658 ]
          Tsz Wo Nicholas Sze added a comment -

          Linking this to HADOOP-2658

          Devaraj Das made changes -
          Fix Version/s 0.19.0 [ 12313211 ]
          Robert Chansler added a comment -

          Gotta be in 0.19!

          Robert Chansler made changes -
          Fix Version/s 0.19.0 [ 12313211 ]
          Priority Major [ 3 ] Blocker [ 1 ]
          Assignee Tsz Wo (Nicholas), SZE [ szetszwo ]
          Tsz Wo Nicholas Sze added a comment -

          After several recent append bug fix patches are committed, this test seems not failing anymore. We should observe this for a few days. We could close this issue if the test does not fail again.

          Tsz Wo Nicholas Sze added a comment -

          No failure is observed after commited HADOOP-3883. Closing this as a duplicate of HADOOP-3883.

          Tsz Wo Nicholas Sze made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Tsz Wo Nicholas Sze made changes -
          Resolution Duplicate [ 3 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          Nigel Daley added a comment -

          Talking with Dhruba, this isn't a blocker for 0.19.0. Assigning to 0.19.1 for now.

          Nigel Daley made changes -
          Fix Version/s 0.19.1 [ 12313473 ]
          Fix Version/s 0.19.0 [ 12313211 ]
          Priority Blocker [ 1 ] Critical [ 2 ]
          Nigel Daley made changes -
          Fix Version/s 0.20.0 [ 12313438 ]
          Nigel Daley made changes -
          Fix Version/s 0.19.2 [ 12313650 ]
          Fix Version/s 0.19.1 [ 12313473 ]
          Tsz Wo Nicholas Sze added a comment -

          This requires the append feature design and code fixes. Closing as "later".

          Tsz Wo Nicholas Sze made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Assignee Tsz Wo (Nicholas), SZE [ szetszwo ]
          Fix Version/s 0.20.0 [ 12313438 ]
          Fix Version/s 0.19.2 [ 12313650 ]
          Resolution Later [ 7 ]
          Owen O'Malley made changes -
          Component/s dfs [ 12310710 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Doug Cutting
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development