Hadoop Common
  1. Hadoop Common
  2. HADOOP-3431

hadoop streaming should kill all children processes on task failure

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The current hadoop streaming will leave the children processes running, when the task failed. We should kill the children processes.

        Issue Links

          Activity

          Lohit Vijayarenu added a comment -

          +1. There are few side effects seen if the child processes are not killed. Eg HADOOP-2427 might be due to that, but never got a chance to confirm that.

          Koji Noguchi added a comment -

          Is HADOOP-2721 related?

          Zheng Shao added a comment -

          yes, but 2721 is for pipes, this is for streaming.

          Devaraj Das added a comment -

          Actually 2721 applies to all components.

          Joydeep Sen Sarma added a comment -

          yeah - same as 2721.

          Zheng Shao added a comment -

          duplicate of HADOOP-2721


            People

            • Assignee:
              Unassigned
              Reporter:
              Zheng Shao
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development