Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.17.0
    • Fix Version/s: 0.17.0
    • Component/s: fs
    • Labels:
      None
    • Environment:

      Windows

      Description

      TestDFSShell.testPut() fails with the following exception:

      Pathname /C:/Hadoop/build/test/data/f1 from C:/Hadoop/build/test/data/f1 is not a valid DFS filename.
      java.lang.IllegalArgumentException: Pathname /C:/Hadoop/build/test/data/f1 from C:/Hadoop/build/test/data/f1 is not a valid DFS filename.
      	at org.apache.hadoop.dfs.DistributedFileSystem.getPathName(DistributedFileSystem.java:112)
      	at org.apache.hadoop.dfs.DistributedFileSystem.exists(DistributedFileSystem.java:184)
      	at org.apache.hadoop.dfs.TestDFSShell.testPut(TestDFSShell.java:214)
      

      Looks like that Path treats windows drive letter incorrectly.
      Not sure which path introduced it, but needs to be fixed for 0.17 imo.

      1. HADOOP-3114-1.patch
        1 kB
        Lohit Vijayarenu

        Activity

        Lohit Vijayarenu added a comment -

        This was caused by HADOOP-3091. I had also missed to update FsShell help message one place, so fixing both in this patch. Tested on windows and it does not fail.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12378755/HADOOP-3114-1.patch
        against trunk revision 619744.

        @author +1. The patch does not contain any @author tags.

        tests included +1. The patch appears to include 3 new or modified tests.

        javadoc -1. The javadoc tool appears to have generated 1 warning messages.

        javac +1. The applied patch does not generate any new javac compiler warnings.

        release audit +1. The applied patch does not generate any new release audit warnings.

        findbugs +1. The patch does not introduce any new Findbugs warnings.

        core tests +1. The patch passed core unit tests.

        contrib tests +1. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2080/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2080/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2080/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/2080/console

        This message is automatically generated.

        Lohit Vijayarenu added a comment -

        javadoc warning seems to be unrelated to this patch

        Chris Douglas added a comment -

        I just committed this. Thanks, Lohit!

        Hudson added a comment -

          People

          • Assignee:
            Lohit Vijayarenu
            Reporter:
            Konstantin Shvachko
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development