Hadoop Common
  1. Hadoop Common
  2. HADOOP-2645

Additional metrics & jmx beans and cleanup to use the recent metrics libraries

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.16.0
    • Component/s: None
    • Labels:
      None

      Description

      This patch does following:

      Data node :
      Additional metrics
      Cleunup old metrics to use recent metrics lib
      MBeans for data node metrics

      Namenode
      Cleunup old updates of metrics to use recent metrics lib
      Split Name none mbean to 2 MBeans - statistics and FSNamesystem status
      rename of name node mbean for consistency.

      1. metrics2.patch
        78 kB
        Sanjay Radia
      2. metrics3.patch
        79 kB
        Sanjay Radia
      3. metrics4.patch
        80 kB
        Sanjay Radia
      4. metrics5.patch
        80 kB
        Sanjay Radia
      5. metrics8.patch
        83 kB
        Sanjay Radia
      6. metrics9.patch
        83 kB
        Sanjay Radia

        Activity

        Hudson added a comment -
        dhruba borthakur added a comment -

        I just committed this. Thanks Sanjay!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12373891/metrics8.patch
        against trunk revision 614721.

        @author +1. The patch does not contain any @author tags.

        javadoc +1. The javadoc tool did not generate any warning messages.

        javac +1. The applied patch does not generate any new compiler warnings.

        findbugs -1. The patch appears to introduce 2 new Findbugs warnings.

        core tests +1. The patch passed core unit tests.

        contrib tests +1. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1656/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1656/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1656/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/1656/console

        This message is automatically generated.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12373802/metrics5.patch
        against trunk revision r614413.

        @author +1. The patch does not contain any @author tags.

        patch -1. The patch command could not apply the patch.

        Console output: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1683/console

        This message is automatically generated.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12373564/metrics4.patch
        against trunk revision r613446.

        @author +1. The patch does not contain any @author tags.

        javadoc +1. The javadoc tool did not generate any warning messages.

        javac +1. The applied patch does not generate any new compiler warnings.

        findbugs +1. The patch does not introduce any new Findbugs warnings.

        core tests -1. The patch failed core unit tests.

        contrib tests +1. The patch passed contrib unit tests.

        Test results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1655/testReport/
        Findbugs warnings: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1655/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1655/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1655/console

        This message is automatically generated.

        Sanjay Radia added a comment -

        I was not able to reproduce the error.
        I have run it several times.
        An updated version off the latest trunk is attached for a retest.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12373463/metrics3.patch
        against trunk revision r613115.

        @author +1. The patch does not contain any @author tags.

        javadoc +1. The javadoc tool did not generate any warning messages.

        javac +1. The applied patch does not generate any new compiler warnings.

        findbugs +1. The patch does not introduce any new Findbugs warnings.

        core tests -1. The patch failed core unit tests.

        contrib tests +1. The patch passed contrib unit tests.

        Test results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1637/testReport/
        Findbugs warnings: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1637/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1637/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1637/console

        This message is automatically generated.

        Sanjay Radia added a comment -

        The MBean server doe snot cal these method automatically.
        It is called on demand if a JMX client call this.

        However since JMX console has a convenient graphing tool for numeric attributes someone could
        graph these it would call these methods.
        I have changed these from attributes to explicit operations.
        Thanks for catching this Raghu.

        Raghu Angadi added a comment -

        Also there are few javadoc warnings.
        are getLiveDatanode() and getDeadDatanode() executed automatically (evey few minutes)?

        apart from this, +1.

        Raghu Angadi added a comment -

        Could you fix the eclipse warnings? E.g. unused imports, members etc ...


          People

          • Assignee:
            Sanjay Radia
            Reporter:
            Sanjay Radia
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development