Hadoop Common
  1. Hadoop Common
  2. HADOOP-2596

add SequenceFile.createWriter() method that takes block size as parameter

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.16.0
    • Component/s: io
    • Labels:
      None
    • Environment:

      all

      Description

      Currently it is not possible to create a SequenceFile.Writer using a block size other than the default.

      The createWriter() method should be overloaded with a signature receiving block size as parameter should be added to the the SequenceFile class.

      With all the current signatures for this method there is a significant code duplication, if possible the createWriter() methods should be refactored to avoid such duplication.

      1. patch2596.txt
        13 kB
        Alejandro Abdelnur

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Alejandro Abdelnur
            Reporter:
            Alejandro Abdelnur
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development