Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-16400

Update Maven Clover plugin to 4.0.6

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Patch Available
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Target Version/s:

      Description

      ERROR when exec  'mvn clean clover2:setup test clover2:aggregate clover2:clover' in hadoop-common cause task failed, below is the info

       

      [WARNING] Some messages have been simplified; recompile with -Xdiags:verbose to get full output
      [INFO] 42 warnings
      [INFO] -------------------------------------------------------------
      [INFO] -------------------------------------------------------------
      [ERROR] COMPILATION ERROR :
      [INFO] -------------------------------------------------------------
      [ERROR] /data4/luhuachao/opensource/hadoop-git/hadoop/hadoop-common-project/hadoop-common/target/clover/src-instrumented/org/apache/hadoop/fs/Options.java:[349,52] reference to resolve is ambiguous
      both method resolve(org.apache.hadoop.fs.FileSystem,org.apache.hadoop.fs.Options.HandleOpt...) in org.apache.hadoop.fs.Options.HandleOpt and method resolve(java.util.function.BiFunction<org.apache.hadoop.fs.FileStatus,org.apache.hadoop.fs.Options.HandleOpt[],org.apache.hadoop.fs.PathHandle>,org.apache.hadoop.fs.Options.HandleOpt...) in org.apache.hadoop.fs.Options.HandleOpt match
      [ERROR] /data4/luhuachao/opensource/hadoop-git/hadoop/hadoop-common-project/hadoop-common/target/clover/src-instrumented/org/apache/hadoop/fs/Options.java:[349,94] incompatible types: cannot infer type-variable(s) I,T
      (argument mismatch; java.lang.Object is not a functional interface)
      [ERROR] /data4/luhuachao/opensource/hadoop-git/hadoop/hadoop-common-project/hadoop-common/target/clover/src-instrumented/org/apache/hadoop/security/RuleBasedLdapGroupsMapping.java:[80,157] incompatible types: inference variable T has incompatible bounds
      equality constraints: java.lang.String
      lower bounds: java.lang.Object
      [ERROR] /data4/luhuachao/opensource/hadoop-git/hadoop/hadoop-common-project/hadoop-common/target/clover/src-instrumented/org/apache/hadoop/security/RuleBasedLdapGroupsMapping.java:[83,157] incompatible types: inference variable T has incompatible bounds
      equality constraints: java.lang.String
      lower bounds: java.lang.Object
      [ERROR] /data4/luhuachao/opensource/hadoop-git/hadoop/hadoop-common-project/hadoop-common/target/clover/src-instrumented/org/apache/hadoop/io/erasurecode/CodecRegistry.java:[123,11] no suitable method found for collect(java.util.stream.Collector<java.lang.CharSequence,capture#1 of ?,java.lang.String>)
      method java.util.stream.Stream.<R>collect(java.util.function.Supplier<R>,java.util.function.BiConsumer<R,? super java.lang.Object>,java.util.function.BiConsumer<R,R>) is not applicable
      (cannot infer type-variable(s) R
      (actual and formal argument lists differ in length))
      method java.util.stream.Stream.<R,A>collect(java.util.stream.Collector<? super java.lang.Object,A,R>) is not applicable
      (cannot infer type-variable(s) R,A
      (argument mismatch; java.util.stream.Collector<java.lang.CharSequence,capture#1 of ?,java.lang.String> cannot be converted to java.util.stream.Collector<? super java.lang.Object,A,R>))
      [INFO] 5 errors
      
      

       

        Attachments

        1. HADOOP-16400-002.patch
          0.7 kB
          luhuachao
        2. HADOOP-16400.patch
          1 kB
          luhuachao

          Activity

            People

            • Assignee:
              Huachao luhuachao
              Reporter:
              Huachao luhuachao
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: