Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha2
    • Component/s: fs/s3
    • Labels:
      None
    • Target Version/s:

      Description

      The test ITestS3AFileContextStatistics.testStatistics() seems to fail pretty reliably these days...I'd assumed it was some race condition, but maybe not.

      Fixing this will probably entail adding more diagnostics to the base test case.

        Issue Links

          Activity

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10642 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10642/)
          HADOOP-13735 ITestS3AFileContextStatistics.testStatistics() failing. (stevel: rev 9ae270af02c243993f853513c731cb268430e492)

          • (edit) hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/S3AFileSystem.java
          • (edit) hadoop-tools/hadoop-aws/src/main/java/org/apache/hadoop/fs/s3a/S3AInstrumentation.java
          stevel@apache.org Steve Loughran added a comment -

          +1

          committed. Thanks Pieter!

          PieterReuse Pieter Reuse added a comment -

          Thank you for uploading my patch, Steve. -1 from Yetus is expected. This patch makes a test pass so no additional tests needed here in my opinion.

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 18s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 6m 27s branch-2 passed
          +1 compile 0m 16s branch-2 passed with JDK v1.8.0_101
          +1 compile 0m 19s branch-2 passed with JDK v1.7.0_111
          +1 checkstyle 0m 15s branch-2 passed
          +1 mvnsite 0m 24s branch-2 passed
          +1 mvneclipse 0m 16s branch-2 passed
          +1 findbugs 0m 34s branch-2 passed
          +1 javadoc 0m 13s branch-2 passed with JDK v1.8.0_101
          +1 javadoc 0m 15s branch-2 passed with JDK v1.7.0_111
          +1 mvninstall 0m 18s the patch passed
          +1 compile 0m 14s the patch passed with JDK v1.8.0_101
          +1 javac 0m 14s the patch passed
          +1 compile 0m 16s the patch passed with JDK v1.7.0_111
          +1 javac 0m 16s the patch passed
          +1 checkstyle 0m 12s the patch passed
          +1 mvnsite 0m 22s the patch passed
          +1 mvneclipse 0m 12s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 44s the patch passed
          +1 javadoc 0m 11s the patch passed with JDK v1.8.0_101
          +1 javadoc 0m 13s the patch passed with JDK v1.7.0_111
          +1 unit 0m 21s hadoop-aws in the patch passed with JDK v1.7.0_111.
          +1 asflicense 0m 17s The patch does not generate ASF License warnings.
          14m 34s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:b59b8b7
          JIRA Issue HADOOP-13735
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12834377/HADOOP-13735-branch-2-001.patch
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux c8f38ac06229 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision branch-2 / 5a37668
          Default Java 1.7.0_111
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_101 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_111
          findbugs v3.0.0
          JDK v1.7.0_111 Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/10840/testReport/
          modules C: hadoop-tools/hadoop-aws U: hadoop-tools/hadoop-aws
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10840/console
          Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

          This message was automatically generated.

          stevel@apache.org Steve Loughran added a comment -

          It's clear this was caused by HADOOP-13560 —sorry to everyone. I think the problem was that this test has been failing intermittently for a while, so we took its failure as just the same ongoing consistency/race condition, when in fact it was a regression.

          this patch should fix it.

          In the previous attempts to fix this patch, I'd moved the test out of the parallel run, into the sequential set. We can look again at that in future ... let's make sure it stabilises first.

          stevel@apache.org Steve Loughran added a comment -

          Patch 001 as emailed to me by Pieter Reuse. Tested locally, s3a ireland all is well, excluding failure in ITestS3AContractRootDir which HADOOP-13716 will address.

          submitting for yetus to review; if it is happy then so am i

          stevel@apache.org Steve Loughran added a comment -
          Running org.apache.hadoop.fs.s3a.fileContext.ITestS3AFileContextStatistics
          Tests run: 3, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 5.823 sec <<< FAILURE! - in org.apache.hadoop.fs.s3a.fileContext.ITestS3AFileContextStatistics
          testStatistics(org.apache.hadoop.fs.s3a.fileContext.ITestS3AFileContextStatistics)  Time elapsed: 3.356 sec  <<< FAILURE!
          java.lang.AssertionError: expected:<512> but was:<0>
          	at org.junit.Assert.fail(Assert.java:88)
          	at org.junit.Assert.failNotEquals(Assert.java:743)
          	at org.junit.Assert.assertEquals(Assert.java:118)
          	at org.junit.Assert.assertEquals(Assert.java:555)
          	at org.junit.Assert.assertEquals(Assert.java:542)
          	at org.apache.hadoop.fs.s3a.fileContext.ITestS3AFileContextStatistics.verifyWrittenBytes(ITestS3AFileContextStatistics.java:54)
          

            People

            • Assignee:
              PieterReuse Pieter Reuse
              Reporter:
              stevel@apache.org Steve Loughran
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development