Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13485

Log refactoring: method invocation should be replaced by variable in hadoop tools

Add voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Patch Available
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.7.2
    • Fix Version/s: None
    • Component/s: tools
    • Labels:

      Description

      Similar to the fix for HDFS-409. In file:

      hadoop-rel-release-2.7.2/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java

      this.blockSize = conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME,
              MAX_AZURE_BLOCK_SIZE);
      if (LOG.isDebugEnabled()) {
          LOG.debug("NativeAzureFileSystem. Initializing.");
          LOG.debug("  blockSize  = "
                + conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE));
      }
      

      For simplicity and readability, the conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE)) should be changed to this.blockSize.

        Attachments

        1. HADOOP-13485.001.patch
          0.9 kB
          Vrushali C

          Activity

          $i18n.getText('security.level.explanation', $currentSelection) Viewable by All Users
          Cancel

            People

            • Assignee:
              Unassigned
              Reporter:
              chenfsd Nemo Chen

              Dates

              • Created:
                Updated:

                Issue deployment