Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13485

Log refactoring: method invocation should be replaced by variable in hadoop tools

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Patch Available
    • Major
    • Resolution: Unresolved
    • 2.7.2
    • None
    • tools

    Description

      Similar to the fix for HDFS-409. In file:

      hadoop-rel-release-2.7.2/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java

      this.blockSize = conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME,
              MAX_AZURE_BLOCK_SIZE);
      if (LOG.isDebugEnabled()) {
          LOG.debug("NativeAzureFileSystem. Initializing.");
          LOG.debug("  blockSize  = "
                + conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE));
      }
      

      For simplicity and readability, the conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE)) should be changed to this.blockSize.

      Attachments

        1. HADOOP-13485.001.patch
          0.9 kB
          Vrushali C

        Activity

          People

            Unassigned Unassigned
            chenfsd Nemo Chen
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated: