Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13485

Log refactoring: method invocation should be replaced by variable in hadoop tools

Log workAgile BoardRank to TopRank to BottomAttach filesAttach ScreenshotBulk Copy AttachmentsBulk Move AttachmentsAdd voteVotersWatch issueWatchersCreate sub-taskConvert to sub-taskMoveLinkCloneLabelsUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Patch Available
    • Major
    • Resolution: Unresolved
    • 2.7.2
    • None
    • tools

    Description

      Similar to the fix for HDFS-409. In file:

      hadoop-rel-release-2.7.2/hadoop-tools/hadoop-azure/src/main/java/org/apache/hadoop/fs/azure/NativeAzureFileSystem.java

      this.blockSize = conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME,
              MAX_AZURE_BLOCK_SIZE);
      if (LOG.isDebugEnabled()) {
          LOG.debug("NativeAzureFileSystem. Initializing.");
          LOG.debug("  blockSize  = "
                + conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE));
      }
      

      For simplicity and readability, the conf.getLong(AZURE_BLOCK_SIZE_PROPERTY_NAME, MAX_AZURE_BLOCK_SIZE)) should be changed to this.blockSize.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned Assign to me
            chenfsd Nemo Chen

            Dates

              Created:
              Updated:

              Slack

                Issue deployment