Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-13240

TestAclCommands.testSetfaclValidations fail

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4.1, 2.7.1
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Environment:

      hadoop 2.4.1,as6.5

    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      mvn test -Djava.net.preferIPv4Stack=true -Dlog4j.rootLogger=DEBUG,console -Dtest=TestAclCommands#testSetfaclValidations failed with following message:
      -------------------------------------------------------------------------------
      Test set: org.apache.hadoop.fs.shell.TestAclCommands
      -------------------------------------------------------------------------------
      Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.599 sec <<< FAILURE! - in org.apache.hadoop.fs.shell.TestAclCommands
      testSetfaclValidations(org.apache.hadoop.fs.shell.TestAclCommands) Time elapsed: 0.534 sec <<< FAILURE!
      java.lang.AssertionError: setfacl should fail ACL spec missing
      at org.junit.Assert.fail(Assert.java:93)
      at org.junit.Assert.assertTrue(Assert.java:43)
      at org.junit.Assert.assertFalse(Assert.java:68)
      at org.apache.hadoop.fs.shell.TestAclCommands.testSetfaclValidations(TestAclCommands.java:81)

      i notice from HADOOP-10277,hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/permission/AclEntry.java code changed

      should hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestAclCommands.javabe changed to:
      diff --git a/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestAclCommands.java b/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestAclCommands.java
      index b14cd37..463bfcd
      — a/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestAclCommands.java
      +++ b/hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestAclCommands.java
      @@ -80,7 +80,7 @@ public void testSetfaclValidations() throws Exception

      { "/path" }

      ));
      assertFalse("setfacl should fail ACL spec missing",
      0 == runCommand(new String[]

      { "-setfacl", "-m", - "", "/path" }

      ));
      + ":", "/path" }));
      }

      @Test

      1. HADOOP-13240.001.patch
        5 kB
        John Zhuge
      2. HADOOP-13240.002.patch
        5 kB
        John Zhuge
      3. HADOOP-13240.003.patch
        5 kB
        John Zhuge
      4. HADOOP-13240.004.patch
        5 kB
        John Zhuge

        Activity

        cnauroth Chris Nauroth added a comment -

        I am not able to repro this test failure. I tried the trunk and branch-2.7 branches.

        linbao111 linbao111 added a comment -

        i run test only on my hadoop2.4.1,and i am sure it will be failed on trunk or 2.7 version....

        cnauroth Chris Nauroth added a comment -

        John Zhuge, I noticed you assigned this issue to yourself. Do you have a repro? I haven't seen the failure yet.

        i run test only on my hadoop2.4.1,and i am sure it will be failed on trunk or 2.7 version....

        If the failure only repros on 2.4.1, but it succeeds in later versions, then we'll likely close this issue. There is no active maintenance of the 2.4 line now.

        jzhuge John Zhuge added a comment -

        Chris Nauroth Feel free to close it. Thanks for the heads up. I planned to reproduce but haven't attempted yet.

        linbao111 linbao111 added a comment -

        sorry,i do test on branch 2.7.1 and trunk,and find the same error info:

        [@test1.heracles.com surefire-reports]# cat org.apache.hadoop.fs.shell.TestAclCommands.txt
        -------------------------------------------------------------------------------
        Test set: org.apache.hadoop.fs.shell.TestAclCommands
        -------------------------------------------------------------------------------
        Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.892 sec <<< FAILURE! - in org.apache.hadoop.fs.shell.TestAclCommands
        testSetfaclValidations(org.apache.hadoop.fs.shell.TestAclCommands) Time elapsed: 0.817 sec <<< FAILURE!
        java.lang.AssertionError: setfacl should fail ACL spec missing
        at org.junit.Assert.fail(Assert.java:88)
        at org.junit.Assert.assertTrue(Assert.java:41)
        at org.junit.Assert.assertFalse(Assert.java:64)
        at org.apache.hadoop.fs.shell.TestAclCommands.testSetfaclValidations(TestAclCommands.java:81)

        cnauroth Chris Nauroth added a comment -

        I've tried multiple branches and multiple dev environments, and I still can't get a repro. linbao111, you might need to do some further troubleshooting in your own environment if we can't find another contributor who can repro the failure.

        jzhuge John Zhuge added a comment -

        I was able to reproduce the failure by adding a file or directory /path on my test host.

        linbao111, please verify that there is /path on you test host. Please remove/rename it temporarily, then run the unit test again.

        jzhuge John Zhuge added a comment -

        For comparison, I ran the setfacl -m "" /path on Ubuntu 14.04:

        $ cat /etc/issue
        Ubuntu 14.04.4 LTS \n \l
        
        $ ls -ld /path
        -rw-rw-r--+ 1 root root 0 Jul 11 21:06 /path
        $ sudo setfacl -m "" /path
        Usage: setfacl [-bkndRLP] { -m|-M|-x|-X ... } file ...
        Try `setfacl --help' for more information.
        $ sudo setfacl -m "user:ubuntu:rw-" /path
        
        jzhuge John Zhuge added a comment -

        The TestAclCommands.testSetfaclValidations tests should use an existing file in test root instead of /path because there is no guarantee which error gets reported when there are 2 errors in command options.

        There is bug in setfacl -m "" <existing file> validation code. At least one valid ACL entry is expected for option -m or -x or --set. Please see FileSystemShell.md. And command setfacl -m "" <existing file> returns error on Linux.

        jzhuge John Zhuge added a comment -

        Patch 001:

        • Report error when <acl_spec> is empty for setfacl -m
        • Fix TestAclCommands to use existing file path instead of /path
        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 17s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 27s trunk passed
        +1 compile 7m 23s trunk passed
        +1 checkstyle 0m 24s trunk passed
        +1 mvnsite 0m 57s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 23s trunk passed
        +1 javadoc 0m 46s trunk passed
        +1 mvninstall 0m 40s the patch passed
        +1 compile 7m 16s the patch passed
        +1 javac 7m 16s the patch passed
        -0 checkstyle 0m 23s hadoop-common-project/hadoop-common: The patch generated 6 new + 39 unchanged - 6 fixed = 45 total (was 45)
        +1 mvnsite 0m 55s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 32s the patch passed
        +1 javadoc 0m 46s the patch passed
        +1 unit 7m 11s hadoop-common in the patch passed.
        +1 asflicense 0m 21s The patch does not generate ASF License warnings.
        39m 29s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12817320/HADOOP-13240.001.patch
        JIRA Issue HADOOP-13240
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux e7f3453b523e 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / f292624
        Default Java 1.8.0_91
        findbugs v3.0.0
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/9963/artifact/patchprocess/diff-checkstyle-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9963/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9963/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jzhuge John Zhuge added a comment -

        Patch 002:

        • Fix checkstyle errors
        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 36s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 7m 11s trunk passed
        +1 compile 7m 16s trunk passed
        +1 checkstyle 0m 23s trunk passed
        +1 mvnsite 0m 58s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 21s trunk passed
        +1 javadoc 0m 47s trunk passed
        +1 mvninstall 0m 39s the patch passed
        +1 compile 7m 19s the patch passed
        +1 javac 7m 19s the patch passed
        +1 checkstyle 0m 23s hadoop-common-project/hadoop-common: The patch generated 0 new + 34 unchanged - 11 fixed = 34 total (was 45)
        +1 mvnsite 0m 55s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 33s the patch passed
        +1 javadoc 0m 47s the patch passed
        +1 unit 7m 4s hadoop-common in the patch passed.
        +1 asflicense 0m 22s The patch does not generate ASF License warnings.
        39m 30s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12817465/HADOOP-13240.002.patch
        JIRA Issue HADOOP-13240
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux ebe9c979f312 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 7705812
        Default Java 1.8.0_91
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/9969/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/9969/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        cnauroth Chris Nauroth added a comment -

        John Zhuge, thank you for finding a repro and coding a patch. This looks good to me overall.

                if (aclEntries.size() == 0) {
        

        A minor nit-pick: please switch to aclEntries.isEmpty() for increased readability.

        Did you also run TestAclCLI in the hadoop-hdfs module with this patch applied? Pre-commit will see this patch as a change in hadoop-common only, so it will only run the tests in that module.

        jzhuge John Zhuge added a comment -

        Patch 003:

        • Use aclEntries.isEmpty()
        • Pass both TestAclCommands and TestAclCLI unit tests
        cnauroth Chris Nauroth added a comment -

        +1, pending another pre-commit run.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 23s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 6m 59s trunk passed
        +1 compile 6m 50s trunk passed
        +1 checkstyle 0m 22s trunk passed
        +1 mvnsite 0m 54s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 17s trunk passed
        +1 javadoc 0m 46s trunk passed
        +1 mvninstall 0m 37s the patch passed
        +1 compile 6m 44s the patch passed
        +1 javac 6m 44s the patch passed
        +1 checkstyle 0m 23s hadoop-common-project/hadoop-common: The patch generated 0 new + 34 unchanged - 11 fixed = 34 total (was 45)
        +1 mvnsite 0m 53s the patch passed
        +1 mvneclipse 0m 12s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 25s the patch passed
        +1 javadoc 0m 46s the patch passed
        -1 unit 19m 26s hadoop-common in the patch failed.
        +1 asflicense 0m 21s The patch does not generate ASF License warnings.
        49m 54s



        Reason Tests
        Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12818914/HADOOP-13240.003.patch
        JIRA Issue HADOOP-13240
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 87f3faeb16f0 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / dc065dd
        Default Java 1.8.0_91
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/10028/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/10028/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10028/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jzhuge John Zhuge added a comment -

        Timed out in unit test org.apache.hadoop.http.TestHttpServerLifecycle. Unrelated.

        cnauroth Chris Nauroth added a comment -

        John Zhuge, I just noticed that if you want to put this into branch-2.8, then we'll need a separate patch for that branch, because it lacks the GenericTestUtils#getTestDir method. You could handle this by inlining the logic of GenericTestUtils#getTestDir directly into the test method, just for branch-2.8. See HADOOP-13145 for an example of one of my patches that needed to handle a similar situation.

        hadoopqa Hadoop QA added a comment -
        +1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 27s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 8m 10s trunk passed
        +1 compile 8m 6s trunk passed
        +1 checkstyle 0m 23s trunk passed
        +1 mvnsite 0m 56s trunk passed
        +1 mvneclipse 0m 13s trunk passed
        +1 findbugs 1m 23s trunk passed
        +1 javadoc 0m 47s trunk passed
        +1 mvninstall 0m 38s the patch passed
        +1 compile 7m 7s the patch passed
        +1 javac 7m 7s the patch passed
        +1 checkstyle 0m 23s hadoop-common-project/hadoop-common: The patch generated 0 new + 34 unchanged - 11 fixed = 34 total (was 45)
        +1 mvnsite 0m 53s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 30s the patch passed
        +1 javadoc 0m 48s the patch passed
        +1 unit 15m 25s hadoop-common in the patch passed.
        +1 asflicense 0m 23s The patch does not generate ASF License warnings.
        49m 7s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12818914/HADOOP-13240.003.patch
        JIRA Issue HADOOP-13240
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux ab98795b6e8d 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 38128ba
        Default Java 1.8.0_91
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/10038/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10038/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jojochuang Wei-Chiu Chuang added a comment -

        Hello John Zhuge thanks for the patch. I think the latest patch looks good to me. One comment I have is the creation of the File object. It seems to be a better practice to initialize it per test, rather than per class (i.e. difference between @Before and @BeforeClass), since these tests modify the properties of the file.

        jzhuge John Zhuge added a comment -

        Thanks for the review Wei-Chiu Chuang! You brought up a valid concern that different test cases could share the same file on the local file system. In Patch 004 I use JUnit TemporaryFolder rule to solve the problem. The rule also cleans up the temp folder after test run.

        Wish we could design a similar mechanism when the common file system is an Hadoop file system, e.g., on MiniDFSCluster.

        Patch 004:

        • Incorporate review comments
        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 21s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        +1 mvninstall 9m 27s trunk passed
        +1 compile 9m 35s trunk passed
        +1 checkstyle 0m 29s trunk passed
        +1 mvnsite 1m 9s trunk passed
        +1 mvneclipse 0m 15s trunk passed
        +1 findbugs 1m 45s trunk passed
        +1 javadoc 0m 56s trunk passed
        +1 mvninstall 0m 47s the patch passed
        +1 compile 8m 37s the patch passed
        +1 javac 8m 37s the patch passed
        +1 checkstyle 0m 27s hadoop-common-project/hadoop-common: The patch generated 0 new + 34 unchanged - 11 fixed = 34 total (was 45)
        +1 mvnsite 1m 6s the patch passed
        +1 mvneclipse 0m 13s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 45s the patch passed
        +1 javadoc 0m 49s the patch passed
        -1 unit 18m 38s hadoop-common in the patch failed.
        +1 asflicense 0m 21s The patch does not generate ASF License warnings.
        58m 10s



        Reason Tests
        Timed out junit tests org.apache.hadoop.http.TestHttpServerLifecycle



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12819281/HADOOP-13240.004.patch
        JIRA Issue HADOOP-13240
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 04af89dc8ba6 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 557a245
        Default Java 1.8.0_91
        findbugs v3.0.0
        unit https://builds.apache.org/job/PreCommit-HADOOP-Build/10051/artifact/patchprocess/patch-unit-hadoop-common-project_hadoop-common.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/10051/testReport/
        modules C: hadoop-common-project/hadoop-common U: hadoop-common-project/hadoop-common
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/10051/console
        Powered by Apache Yetus 0.4.0-SNAPSHOT http://yetus.apache.org

        This message was automatically generated.

        jzhuge John Zhuge added a comment -

        Timed out in unit test org.apache.hadoop.http.TestHttpServerLifecycle. Unrelated.

        cnauroth Chris Nauroth added a comment -

        +1 for patch 004. This one works fine for branch-2.8 too.

        John Zhuge, I see you switched the target version to 3.0.0-alpha2. Now that we have patch compatible with branch-2.8, do you mind if I target this to 2.8.0? Let me know if there is any reason you don't want it there.

        jzhuge John Zhuge added a comment -

        I switched before finding a nice solution in TemporaryFolder JUnit rule for this case. Target it 2.8.0 now.

        cnauroth Chris Nauroth added a comment -

        I have committed this to trunk, branch-2 and branch-2.8. John Zhuge, thank you for the patch. Wei-Chiu Chuang, thank you for your review comments.

        jzhuge John Zhuge added a comment -

        Thanks Wei-Chiu Chuang and Chris Nauroth for the review and commit.

        hudson Hudson added a comment -

        ABORTED: Integrated in Hadoop-trunk-Commit #10132 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10132/)
        HADOOP-13240. TestAclCommands.testSetfaclValidations fail. Contributed (cnauroth: rev 43cf6b101dacd96bacfd199826b717f6946109af)

        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/AclCommands.java
        • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestAclCommands.java

          People

          • Assignee:
            jzhuge John Zhuge
            Reporter:
            linbao111 linbao111
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development