Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12478

Shell.getWinUtilsPath() has been renamed Shell.getWinutilsPath()

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: util
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      The shell enhancements of HADOOP-10775 managed to unintentionally change Shell.getWinUtilsPath() has been renamed Shell.getWinutilsPath(). This didn't crop in Hadoop's code, but it's broken some of my stuff downstream -stuff in Groovy which the IDE didn't pick up as a regression.

      I'll fix things by renaming the method to its original name, and changing the name of the getWinutilsFile() to match

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stevel@apache.org Steve Loughran
                Reporter:
                stevel@apache.org Steve Loughran
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1h
                  1h
                  Remaining:
                  Remaining Estimate - 1h
                  1h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified