Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12441

Fix kill command behavior under some Linux distributions.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      After HADOOP-12317, kill command's execution will be failure under Ubuntu12. After NM restarts, it cannot get if a process is alive or not via pid of containers, and it cannot kill process correctly when RM/AM tells NM to kill a container.

      Logs from NM (customized logs):

      2015-09-25 21:58:59,348 INFO  nodemanager.DefaultContainerExecutor (DefaultContainerExecutor.java:containerIsAlive(431)) -  ================== check alive cmd:[[Ljava.lang.String;@496e442d]
      2015-09-25 21:58:59,349 INFO  nodemanager.NMAuditLogger (NMAuditLogger.java:logSuccess(89)) - USER=hrt_qa       IP=10.0.1.14    OPERATION=Stop Container Request        TARGET=ContainerManageImpl      RESULT=SUCCESS  APPID=application_1443218269460_0001    CONTAINERID=container_1443218269460_0001_01_000001
      2015-09-25 21:58:59,363 INFO  nodemanager.DefaultContainerExecutor (DefaultContainerExecutor.java:containerIsAlive(438)) -  ===========================
      ExitCodeException exitCode=1: ERROR: garbage process ID "--".
      Usage:
        kill pid ...              Send SIGTERM to every process listed.
        kill signal pid ...       Send a signal to every process listed.
        kill -s signal pid ...    Send a signal to every process listed.
        kill -l                   List all signal names.
        kill -L                   List all signal names in a nice table.
        kill -l signal            Convert between signal numbers and names.
      
              at org.apache.hadoop.util.Shell.runCommand(Shell.java:550)
              at org.apache.hadoop.util.Shell.run(Shell.java:461)
              at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(Shell.java:727)
              at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.containerIsAlive(DefaultContainerExecutor.java:432)
              at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.signalContainer(DefaultContainerExecutor.java:401)
              at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.cleanupContainer(ContainerLaunch.java:419)
              at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainersLauncher.handle(ContainersLauncher.java:139)
              at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainersLauncher.handle(ContainersLauncher.java:55)
              at org.apache.hadoop.yarn.event.AsyncDispatcher.dispatch(AsyncDispatcher.java:175)
              at org.apache.hadoop.yarn.event.AsyncDispatcher$1.run(AsyncDispatcher.java:108)
              at java.lang.Thread.run(Thread.java:745)
      
      1. HADOOP-12441.1.patch
        7 kB
        Wangda Tan
      2. HADOOP-12441.2.patch
        9 kB
        Wangda Tan
      3. HADOOP-12441.4.patch
        6 kB
        Wangda Tan

        Issue Links

          Activity

          leftnoteasy Wangda Tan added a comment -

          The root cause of this issue is:

          There're two different kinds of kill in popular Linux distributions, one comes from bash, which a bash built in. Another one comes from system, located at /bin/kill.

          When running which kill, it shows /bin/kill, but if running type -a kill, it tells you the truth:

          user@workernode1:~$ type -a kill
          kill is a shell builtin
          kill is /bin/kill
          

          After HADOOP-12317, kill command becomes:

          kill -0 – -<pid>

          Bash built-in kill cmd can support syntax like this, but /bin/kill doesn't support it. By some reason, Hadoop Shell pickes up /bin/kill instead of bash built-in kill.

          Steps to reproduce this issue (Ubuntu 12.04)
          1) Run nohup sleep 1000 &
          2) Run ps -ef | grep sleep

          hrt_qa@workernode1:~$ ps -ef | grep sleep
          hrt_qa   46531 44212  0 23:29 pts/1    00:00:00 sleep 1000
          

          3) Run kill (or bin/kill) -0 – -44212, kill and /bin/kill has different behavior.

          Tested Ubuntu 14, it doesn't have this issue.

          leftnoteasy Wangda Tan added a comment -
          leftnoteasy Wangda Tan added a comment -

          Some proposals of this issue:
          Proposal#1. Use "bash -c" to execute the kill command so it will pick the bash built-in kill? The problem is, do we have other Linux distribution doesn't have bash support? Since we uses bash in ContainerLaunch, it shouldn't be a big problem. Another problem we may need to double check is: Some bash-kill could also violate the "--" POSIX recommendation like bin/kill

          Proposal#2. Choose different kill args depends on different version of OS/kill.

          Proposal#3. Run check command similar to what we did for "setsid" (for example: "kill -0 -- -1"). Choose different kill args depends on exit code.

          Any suggestions?

          Thanks,

          leftnoteasy Wangda Tan added a comment -

          Uploading an initial patch for review:

          • Use {{bash -c "kill ..."} instead of {{kill ... }}
          • Check if OS supports bash in NM, if a Unix-based system doesn't support bash, it will fail when trying to launch containers (ContainerLaunch.java uses bash for Unix systems).
          • Check if -- supported in bash built-in kill, I've tested at centos 6/7, ubuntu 12/14, debian 6/7, it works fine, just add this in case.
          vinodkv Vinod Kumar Vavilapalli added a comment -

          Can you comment on how "echo 1000 | kill -0 – -1" is supposed to work? There are no timing issues possible? May be even leave a code comment.

          W.r.t the YARN changes for bash, we should crash the NM instead of failing every single container.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          -1 pre-patch 18m 39s Pre-patch trunk has 1 extant Findbugs (version 3.0.0) warnings.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 55s There were no new javac warning messages.
          +1 javadoc 10m 10s There were no new javadoc warning messages.
          +1 release audit 0m 24s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 24s The applied patch generated 3 new checkstyle issues (total was 98, now 99).
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 30s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 3m 6s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          -1 common tests 6m 30s Tests failed in hadoop-common.
          +1 yarn tests 8m 25s Tests passed in hadoop-yarn-server-nodemanager.
              58m 54s  



          Reason Tests
          Failed unit tests hadoop.fs.shell.TestTextCommand
            hadoop.metrics2.impl.TestGangliaMetrics
            hadoop.net.TestDNS



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12764080/HADOOP-12441.1.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 4c9497c
          Pre-patch Findbugs warnings https://builds.apache.org/job/PreCommit-HADOOP-Build/7719/artifact/patchprocess/trunkFindbugsWarningshadoop-common.html
          checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/7719/artifact/patchprocess/diffcheckstylehadoop-common.txt
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7719/artifact/patchprocess/testrun_hadoop-common.txt
          hadoop-yarn-server-nodemanager test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7719/artifact/patchprocess/testrun_hadoop-yarn-server-nodemanager.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7719/testReport/
          Java 1.7.0_55
          uname Linux asf900.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7719/console

          This message was automatically generated.

          leftnoteasy Wangda Tan added a comment -

          Attached ver.2 addressed Vinod Kumar Vavilapalli's comment

          • Removed the piped echo hack, using kill -0 – 1 since PID==1 process is always existed.
          • Fail NM if when no bash found in Unix-based system.
          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          -1 pre-patch 19m 10s Pre-patch trunk has 1 extant Findbugs (version 3.0.0) warnings.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 9m 49s There were no new javac warning messages.
          +1 javadoc 12m 17s There were no new javadoc warning messages.
          +1 release audit 0m 27s The applied patch does not increase the total number of release audit warnings.
          -1 checkstyle 1m 33s The applied patch generated 4 new checkstyle issues (total was 98, now 100).
          +1 whitespace 0m 1s The patch has no lines that end in whitespace.
          +1 install 1m 56s mvn install still works.
          +1 eclipse:eclipse 0m 44s The patch built with eclipse:eclipse.
          +1 findbugs 4m 9s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          -1 common tests 7m 51s Tests failed in hadoop-common.
          -1 yarn tests 9m 28s Tests failed in hadoop-yarn-server-nodemanager.
              67m 43s  



          Reason Tests
          Failed unit tests hadoop.ipc.TestIPC
            hadoop.yarn.server.nodemanager.TestNodeStatusUpdaterForLabels



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12764107/HADOOP-12441.2.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / ab11085
          Pre-patch Findbugs warnings https://builds.apache.org/job/PreCommit-HADOOP-Build/7723/artifact/patchprocess/trunkFindbugsWarningshadoop-common.html
          checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/7723/artifact/patchprocess/diffcheckstylehadoop-common.txt
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7723/artifact/patchprocess/testrun_hadoop-common.txt
          hadoop-yarn-server-nodemanager test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7723/artifact/patchprocess/testrun_hadoop-yarn-server-nodemanager.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7723/testReport/
          Java 1.7.0_55
          uname Linux asf905.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7723/console

          This message was automatically generated.

          leftnoteasy Wangda Tan added a comment -

          Attached ver.4 patch, tested on RHEL6/Ubuntu12/Ubuntu14, kill command works well.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 15m 46s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 58s There were no new javac warning messages.
          +1 javadoc 10m 10s There were no new javadoc warning messages.
          +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 31s mvn install still works.
          +1 eclipse:eclipse 0m 35s The patch built with eclipse:eclipse.
          -1 common tests 7m 30s Tests failed in hadoop-common.
          +1 yarn tests 8m 21s Tests passed in hadoop-yarn-server-nodemanager.
              52m 18s  



          Reason Tests
          Failed unit tests hadoop.metrics2.impl.TestGangliaMetrics
            hadoop.ipc.TestIPC



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12764161/HADOOP-12441.4.patch
          Optional Tests javadoc javac unit
          git revision trunk / 151fca5
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7728/artifact/patchprocess/testrun_hadoop-common.txt
          hadoop-yarn-server-nodemanager test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7728/artifact/patchprocess/testrun_hadoop-yarn-server-nodemanager.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7728/testReport/
          Java 1.7.0_55
          uname Linux asf903.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7728/console

          This message was automatically generated.

          leftnoteasy Wangda Tan added a comment -

          Ran failed tests with patch locally, all passed.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Looks good, +1. Rekicking Jenkins to be sure of the tests.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 16m 0s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 8m 4s There were no new javac warning messages.
          +1 javadoc 10m 17s There were no new javadoc warning messages.
          -1 release audit 0m 16s The applied patch generated 1 release audit warnings.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 30s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          -1 common tests 7m 6s Tests failed in hadoop-common.
          +1 yarn tests 8m 32s Tests passed in hadoop-yarn-server-nodemanager.
              52m 21s  



          Reason Tests
          Failed unit tests hadoop.metrics2.impl.TestGangliaMetrics
          Timed out tests org.apache.hadoop.ha.TestZKFailoverController
            org.apache.hadoop.ha.TestZKFailoverControllerStress
            org.apache.hadoop.security.ssl.TestReloadingX509TrustManager
            org.apache.hadoop.security.ssl.TestSSLFactory



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12764161/HADOOP-12441.4.patch
          Optional Tests javadoc javac unit
          git revision trunk / fdf02d1
          Release Audit https://builds.apache.org/job/PreCommit-HADOOP-Build/7761/artifact/patchprocess/patchReleaseAuditProblems.txt
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7761/artifact/patchprocess/testrun_hadoop-common.txt
          hadoop-yarn-server-nodemanager test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7761/artifact/patchprocess/testrun_hadoop-yarn-server-nodemanager.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7761/testReport/
          Java 1.7.0_55
          uname Linux asf903.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7761/console

          This message was automatically generated.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Both the RAT warning and the test failures are unrelated, will see if there are tickets already.

          Checking this in now.

          vinodkv Vinod Kumar Vavilapalli added a comment -

          Committed this to trunk and branch-2. Thanks Wangda!

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8569 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8569/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2425 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2425/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          leftnoteasy Wangda Tan added a comment -

          Thanks for Vinod's review and commit!

          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #489 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/489/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #1220 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1220/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #481 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/481/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #456 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/456/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2396 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2396/)
          HADOOP-12441. Fixed shell-kill command behaviour to work correctly on (vinodkv: rev f1c19b9365cbac88e45a9eed516fbfc6c9aa9947)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/util/Shell.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/util/TestShell.java
          • hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager/src/main/java/org/apache/hadoop/yarn/server/nodemanager/NodeManager.java
          stevel@apache.org Steve Loughran added a comment -

          -008 patch; 007 without some whitespace stripping by an overzealous IDE (atom on windows)

          stevel@apache.org Steve Loughran added a comment -

          (sorry, wrong issue, was commenting on HADOOP-10775, which is indirectly related to this one)


            People

            • Assignee:
              leftnoteasy Wangda Tan
              Reporter:
              leftnoteasy Wangda Tan
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development