Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-12252

LocalDirAllocator should not throw NPE with empty string configuration.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: fs
    • Labels:
      None

      Description

      LocalDirAllocator should not throw NPE with empty string configuration. When an empty string is configured, LocalDirAllocator will throw NPE. It will be better to throw IOException instead of NPE.

        Issue Links

          Activity

          zxu zhihai xu added a comment -

          I uploaded a patch HADOOP-12252.000.patch for review. The test in the patch will fail without the fix. The patch will throw IOException if an empty string is configured.

          brahmareddy Brahma Reddy Battula added a comment -

          dupe of HADOOP-8437..?

          zxu zhihai xu added a comment -

          Thanks Brahma Reddy Battula for the information, I looked at HADOOP-8437. They looks like two different issues.
          This NPE happened here is because the newLocalDirs with empty string configuration is equals to the initial value savedLocalDirs.

          private String savedLocalDirs = "";
          

          So localDirs is not updated. the initial value of localDirs is null, which cause NPE at int numDirs = localDirs.length;
          This NPE issue is caused by NULL initial value of localDirs.

          For HADOOP-8437, the problem is due to failing to create the path or DiskErrorException, which cause zero size directory list.

          brahmareddy Brahma Reddy Battula added a comment -

          Yes, you are correct.. thanks for you info..Just now I looked at your patch.

          zxu zhihai xu added a comment -

          The following is the stack trace for the NPE:

          2015-07-22 14:33:43,338 INFO  fs.TestLocalDirAllocator (TestLocalDirAllocator.java:testShouldNotthrowNPE(332)) - NPE
          java.lang.NullPointerException
          	at org.apache.hadoop.fs.LocalDirAllocator$AllocatorPerContext.getLocalPathForWrite(LocalDirAllocator.java:348)
          	at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathForWrite(LocalDirAllocator.java:150)
          	at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathForWrite(LocalDirAllocator.java:131)
          	at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathForWrite(LocalDirAllocator.java:115)
          	at org.apache.hadoop.fs.TestLocalDirAllocator.testShouldNotthrowNPE(TestLocalDirAllocator.java:325)
          	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          	at java.lang.reflect.Method.invoke(Method.java:606)
          	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
          	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
          	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
          	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
          	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
          
          2015-07-22 14:38:54,769 INFO  fs.TestLocalDirAllocator (TestLocalDirAllocator.java:testShouldNotthrowNPE(345)) - NPE
          java.lang.NullPointerException
          	at org.apache.hadoop.fs.LocalDirAllocator$AllocatorPerContext.getLocalPathToRead(LocalDirAllocator.java:436)
          	at org.apache.hadoop.fs.LocalDirAllocator.getLocalPathToRead(LocalDirAllocator.java:164)
          	at org.apache.hadoop.fs.TestLocalDirAllocator.testShouldNotthrowNPE(TestLocalDirAllocator.java:338)
          	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          	at java.lang.reflect.Method.invoke(Method.java:606)
          	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
          	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
          	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
          	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
          	at org.junit.internal.runners.statements.FailOnTimeout$StatementThread.run(FailOnTimeout.java:74)
          

          newLocalDirs.equals(savedLocalDirs) will be true with empty string configuration in AllocatorPerContext#confChanged

          hadoopqa Hadoop QA added a comment -



          +1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 16m 24s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 34s There were no new javac warning messages.
          +1 javadoc 9m 41s There were no new javadoc warning messages.
          +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 1m 5s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 19s mvn install still works.
          +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
          +1 findbugs 1m 52s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          +1 common tests 22m 20s Tests passed in hadoop-common.
              61m 17s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12747211/HADOOP-12252.000.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 156f24e
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/7339/artifact/patchprocess/testrun_hadoop-common.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/7339/testReport/
          Java 1.7.0_55
          uname Linux asf906.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/7339/console

          This message was automatically generated.

          zxu zhihai xu added a comment -

          Xuan Gong, Could you review the patch? Because the arrays dirDF and localDirs are not initialized, NPE will happen when accessing the arrays' length at above corner case. The fix is to initialize dirDF and localDirs as zero length array, which should be safe I think. thanks

          xgong Xuan Gong added a comment -

          zhihai xu Sure. will review it shortly

          xgong Xuan Gong added a comment -

          Thanks for working on this. zhihai xu But I am still not sure why we should make this changes. I think that this is only the test case issue. For the directory, such as NM_LOCAL_DIRS, if we do not set it in configuration, the default value will be used. So, i think that it will not be null.

          What do you think ?

          zxu zhihai xu added a comment -

          thanks Xuan Gong for the review. Normally we won't see this issue, as you said the default value should not be empty string. But there is a usage case at LocalDirsHandlerService, we will change NM_LOCAL_DIRS/NM_LOG_DIRS after disk check.

              List<String> localDirs = getLocalDirs();
              conf.setStrings(YarnConfiguration.NM_LOCAL_DIRS,
                              localDirs.toArray(new String[localDirs.size()]));
              List<String> logDirs = getLogDirs();
              conf.setStrings(YarnConfiguration.NM_LOG_DIRS,
                                logDirs.toArray(new String[logDirs.size()]));
          

          Potentially all disks can be full, although it should very rarely happen. But if it happens, NM_LOCAL_DIRS/NM_LOG_DIRS will be set to empty string and this issue my happen.
          By the way, I find this issue when I worked on the patch at YARN-3925, the test case at YARN-3925 can also reproduce this issue.
          Since this issue rarely happens, I will change its priority to minor.

          zxu zhihai xu added a comment -

          Currently savedLocalDirs at AllocatorPerContext is initialized as ""(empty string). I think it seems reasonable to initialize dirDF and localDirs as zero length array to match the initial value of savedLocalDirs and fix the NPE. Xuan Gong, What do you think?

          xgong Xuan Gong added a comment -

          +1 LGTM

          zxu zhihai xu added a comment -

          thanks Xuan Gong for the review! Committed it to branch-2 and trunk.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8515 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8515/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #437 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/437/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #1176 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1176/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #443 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/443/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2354 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2354/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #415 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/415/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2382 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2382/)
          HADOOP-12252. LocalDirAllocator should not throw NPE with empty string configuration. Contributed by Zhihai Xu (zxu: rev 52c1f272ecb6c29c81898a1ff50d03a1296df1f7)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/LocalDirAllocator.java
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/TestLocalDirAllocator.java
          • hadoop-common-project/hadoop-common/CHANGES.txt

            People

            • Assignee:
              zxu zhihai xu
              Reporter:
              zxu zhihai xu
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development