Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-11242

Record the time of calling in tracing span of IPC server

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: ipc
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Current tracing span starts when the Call is put into callQueue. Recording the time of calling is useful to debug.

      1. HADOOP-11242.1.patch
        2 kB
        Masatake Iwasaki
      2. HADOOP-11242.1.patch
        2 kB
        Masatake Iwasaki
      3. HADOOP-11242.002.patch
        2 kB
        Masatake Iwasaki
      4. HADOOP-11242.003.patch
        2 kB
        Masatake Iwasaki
      5. HADOOP-11242-test.patch
        2 kB
        Akira Ajisaka
      6. ScreenShot-test.png
        31 kB
        Akira Ajisaka

        Activity

        iwasakims Masatake Iwasaki added a comment -

        attaching patch.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org
        against trunk revision 8984e9b.

        -1 patch. The patch command could not apply the patch.

        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4970//console

        This message is automatically generated.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12677775/HADOOP-11242.1.patch
        against trunk revision 675bca2.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-hdfs-project/hadoop-hdfs:

        org.apache.hadoop.hdfs.web.TestWebHDFSXAttr

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-HADOOP-Build/4976//testReport/
        Console output: https://builds.apache.org/job/PreCommit-HADOOP-Build/4976//console

        This message is automatically generated.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 41s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 30s There were no new javac warning messages.
        +1 javadoc 9m 34s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 2m 9s The applied patch generated 1 new checkstyle issues (total was 218, now 218).
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 32s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 4m 42s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 common tests 23m 35s Tests passed in hadoop-common.
        -1 hdfs tests 165m 27s Tests failed in hadoop-hdfs.
            231m 14s  



        Reason Tests
        Failed unit tests hadoop.tracing.TestTracing



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12677775/HADOOP-11242.1.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / e8d0ee5
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/6450/artifact/patchprocess/diffcheckstylehadoop-common.txt
        hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6450/artifact/patchprocess/testrun_hadoop-common.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6450/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6450/testReport/
        Java 1.7.0_55
        uname Linux asf900.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6450/console

        This message was automatically generated.

        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 35s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 30s There were no new javac warning messages.
        +1 javadoc 9m 39s There were no new javadoc warning messages.
        +1 release audit 0m 21s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 2m 7s The applied patch generated 1 new checkstyle issues (total was 218, now 218).
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 34s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 4m 44s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
        +1 common tests 23m 36s Tests passed in hadoop-common.
        -1 hdfs tests 165m 0s Tests failed in hadoop-hdfs.
            230m 48s  



        Reason Tests
        Failed unit tests hadoop.tracing.TestTracing



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12677775/HADOOP-11242.1.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / a319771
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/6464/artifact/patchprocess/diffcheckstylehadoop-common.txt
        hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6464/artifact/patchprocess/testrun_hadoop-common.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6464/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6464/testReport/
        Java 1.7.0_55
        uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6464/console

        This message was automatically generated.

        ozawa Tsuyoshi Ozawa added a comment -

        Masatake Iwasaki thanks for your contribution. Could you check the test failure of hadoop.tracing.TestTracing?

        java.lang.NullPointerException: null
        	at org.apache.hadoop.tracing.TestTracing.readWithTracing(TestTracing.java:153)
        	at org.apache.hadoop.tracing.TestTracing.testTracing(TestTracing.java:68)
        
        iwasakims Masatake Iwasaki added a comment -

        Thanks for pinging me, Tsuyoshi Ozawa. The test failure is relevant. The patch was applied to unintended part of TestTracing by the change in HDFS-8063. I attached 002 patch which is rebased.

        hadoopqa Hadoop QA added a comment -

        The patch artifact directory has been removed!
        This is a fatal error for test-patch.sh. Aborting.
        Jenkins (node H3) information at https://builds.apache.org/job/PreCommit-HADOOP-Build/6475/ may provide some hints.

        iwasakims Masatake Iwasaki added a comment -

        I attached rebased patch.

        The checkstyle error is not caused by the patch and there is no quick fix. Maybe should be addressed later.

        Server.java:1: File length is 2,931 lines
        
        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 38s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 28s There were no new javac warning messages.
        +1 javadoc 9m 40s There were no new javadoc warning messages.
        +1 release audit 0m 21s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 2m 24s The applied patch generated 1 new checkstyle issues (total was 218, now 218).
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 36s mvn install still works.
        +1 eclipse:eclipse 0m 33s The patch built with eclipse:eclipse.
        +1 findbugs 4m 39s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 common tests 22m 31s Tests passed in hadoop-common.
        +1 hdfs tests 162m 13s Tests passed in hadoop-hdfs.
            227m 17s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12731539/HADOOP-11242.003.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / cdbd66b
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/6836/artifact/patchprocess/diffcheckstylehadoop-common.txt
        hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6836/artifact/patchprocess/testrun_hadoop-common.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6836/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6836/testReport/
        Java 1.7.0_55
        uname Linux asf906.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6836/console

        This message was automatically generated.

        ajisakaa Akira Ajisaka added a comment -

        Looks good to me, +1. I used HADOOP-11242-test.patch to delay putting Call into callQueue in 10ms to verify the time is recorded and delayed.


        Yeah! A red dot, which specifies the elapsed time when the Call got out of callQueue, is added > 10ms after the span starts.

        ajisakaa Akira Ajisaka added a comment -

        Committed this to trunk and branch-2. Thanks Masatake Iwasaki for contribution.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #7907 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7907/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hadoopqa Hadoop QA added a comment -



        -1 overall



        Vote Subsystem Runtime Comment
        0 pre-patch 14m 30s Pre-patch trunk compilation is healthy.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
        +1 javac 7m 26s There were no new javac warning messages.
        +1 javadoc 9m 38s There were no new javadoc warning messages.
        +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
        -1 checkstyle 2m 16s The applied patch generated 1 new checkstyle issues (total was 218, now 218).
        +1 whitespace 0m 0s The patch has no lines that end in whitespace.
        +1 install 1m 36s mvn install still works.
        +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
        +1 findbugs 4m 42s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
        +1 common tests 23m 28s Tests passed in hadoop-common.
        +1 hdfs tests 163m 18s Tests passed in hadoop-hdfs.
            229m 3s  



        Subsystem Report/Notes
        Patch URL http://issues.apache.org/jira/secure/attachment/12731539/HADOOP-11242.003.patch
        Optional Tests javadoc javac unit findbugs checkstyle
        git revision trunk / cdbd66b
        checkstyle https://builds.apache.org/job/PreCommit-HADOOP-Build/6842/artifact/patchprocess/diffcheckstylehadoop-common.txt
        hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6842/artifact/patchprocess/testrun_hadoop-common.txt
        hadoop-hdfs test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6842/artifact/patchprocess/testrun_hadoop-hdfs.txt
        Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6842/testReport/
        Java 1.7.0_55
        uname Linux asf906.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6842/console

        This message was automatically generated.

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk #940 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/940/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #210 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/210/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #208 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/208/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2138 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2138/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #198 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/198/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2156 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2156/)
        HADOOP-11242. Record the time of calling in tracing span of IPC server. Contributed by Mastake Iwasaki. (aajisaka: rev bb1816328a36ec3f8c6bd9fdb950d9a4ec8388c8)

        • hadoop-hdfs-project/hadoop-hdfs/src/test/java/org/apache/hadoop/tracing/TestTracing.java
        • hadoop-common-project/hadoop-common/CHANGES.txt
        • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/ipc/Server.java

          People

          • Assignee:
            iwasakims Masatake Iwasaki
            Reporter:
            iwasakims Masatake Iwasaki
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development