Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-10971

Add -C flag to make `hadoop fs -ls` print filenames only

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: fs
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      It would be useful to have a flag that made hadoop fs -ls only print filenames, instead of full stat info. The "-C" flag from GNU ls is the closest analog to this behavior that I've found, so I propose that as the flag.

      Per this stackoverflow answer, I've reluctantly added a hadoop-ls-C wrapper that expands to hadoop fs -ls "$@" | sed 1d | perl -wlne'print +(split " ",$_,8)[7]' to a few projects I've worked on, and it would obviously be nice to have hadoop save me (and others) from such hackery.

      1. HADOOP-10971.001.patch
        6 kB
        Kengo Seki
      2. HADOOP-10971.002.patch
        6 kB
        Kengo Seki
      3. HADOOP-10971.003.patch
        12 kB
        Kengo Seki
      4. HADOOP-10971.004.patch
        14 kB
        Kengo Seki
      5. HADOOP-10971.005.patch
        13 kB
        Kengo Seki

        Issue Links

          Activity

          aw Allen Wittenauer added a comment -

          I wonder if we should just change the default behavior of ls to not print and add the -l flag instead.

          Of course, this is an incompatible change and would only be allowed in trunk.

          rdub Ryan Williams added a comment -

          Interesting suggestion; if keeping the default and adding the flag allowed for sooner release, I'd lean towards going that route; it's not that big of a deal to have different semantics between hadoop- and non-hadoop-ls.

          Also, adding -C could be viewed as the first step towards a world where -l and -C both exist, in which world the default could be changed less disruptively, since people would be able to get either format before and after the incompatible change.

          In any case, I'd prefer to focus on the (relatively simpler) -C addition here first, but that's just my $0.02.

          aw Allen Wittenauer added a comment -

          Also, adding -C could be viewed as the first step towards a world where -l and -C both exist, in which world the default could be changed less disruptively, since people would be able to get either format before and after the incompatible change.

          Agree: I think this is the way to go.

          cmccabe Colin P. McCabe added a comment -

          Adding -C sounds like a good idea.

          sekikn Kengo Seki added a comment -

          Attaching a patch.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 14m 40s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 31s There were no new javac warning messages.
          +1 javadoc 9m 39s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 1m 1s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 33s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 1m 40s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          -1 common tests 22m 52s Tests failed in hadoop-common.
              59m 53s  



          Reason Tests
          Failed unit tests hadoop.fs.shell.TestLs
            hadoop.cli.TestCLI



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12729760/HADOOP-10971.001.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 1b3b9e5
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6235/artifact/patchprocess/testrun_hadoop-common.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6235/testReport/
          Java 1.7.0_55
          uname Linux asf902.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6235/console

          This message was automatically generated.

          sekikn Kengo Seki added a comment -

          Sorry for submitting an invalid patch. I'll submit the valid one later.

          sekikn Kengo Seki added a comment -

          Attaching the revised patch.

          ajisakaa Akira Ajisaka added a comment -

          Thanks Kengo Seki for taking this issue. Two comments:

          +    inOrder.verify(out).println("Found 6 items");
          

          1. I'm thinking displaying the header such as "Found 6 items" is unnecessarily.
          2. Would you please update the document?

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 15m 2s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 43s There were no new javac warning messages.
          +1 javadoc 9m 58s There were no new javadoc warning messages.
          +1 release audit 0m 23s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 1m 6s There were no new checkstyle issues.
          -1 whitespace 0m 0s The patch has 1 line(s) that end in whitespace. Use git apply --whitespace=fix.
          +1 install 1m 37s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 1m 43s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          -1 common tests 22m 29s Tests failed in hadoop-common.
              60m 39s  



          Reason Tests
          Failed unit tests hadoop.cli.TestCLI
            hadoop.fs.shell.TestLs



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12729996/HADOOP-10971.002.patch
          Optional Tests javadoc javac unit findbugs checkstyle
          git revision trunk / 449e442
          whitespace https://builds.apache.org/job/PreCommit-HADOOP-Build/6514/artifact/patchprocess/whitespace.txt
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6514/artifact/patchprocess/testrun_hadoop-common.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6514/testReport/
          Java 1.7.0_55
          uname Linux asf904.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6514/console

          This message was automatically generated.

          sekikn Kengo Seki added a comment -

          Thanks Akira Ajisaka for your comment. I'll reflect it.
          By the way, I can't reproduce the test failure above in my environment.
          And the whitespace error seems to occur for an unrelated file TestPath.java. The patch doesn't touch it.

          sekikn Kengo Seki added a comment -

          I was wrong. TestLs#processPathDirectoryPathOnly was failed also in my environment.
          So I'm attaching the revised patch. In this,

          • fixed the unit test failure
          • removed "Found n items" message when -C is specified
          • updated the document
          • made -C to overrule -u, because timestamp isn't displayed when -C is specified
          • moved the variables and functions related to -C option before -d option, because they are sorted in alphabetical order in the existing code
          • add test cases and modified existing ones because the previous patch was not sufficient
          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 17m 30s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 7m 29s There were no new javac warning messages.
          +1 javadoc 9m 40s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 site 2m 57s Site still builds.
          +1 checkstyle 1m 4s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 34s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 1m 38s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          -1 common tests 22m 30s Tests failed in hadoop-common.
              65m 19s  



          Reason Tests
          Failed unit tests hadoop.cli.TestCLI



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12733305/HADOOP-10971.003.patch
          Optional Tests javadoc javac unit findbugs checkstyle site
          git revision trunk / b0ad644
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6708/artifact/patchprocess/testrun_hadoop-common.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6708/testReport/
          Java 1.7.0_55
          uname Linux asf901.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6708/console

          This message was automatically generated.

          sekikn Kengo Seki added a comment -

          Fixed TestCLI failure.
          Thanks Akira Ajisaka for your offline comment.

          hadoopqa Hadoop QA added a comment -



          +1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 17m 36s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 2 new or modified test files.
          +1 javac 7m 30s There were no new javac warning messages.
          +1 javadoc 9m 37s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 site 2m 58s Site still builds.
          +1 checkstyle 1m 4s There were no new checkstyle issues.
          +1 whitespace 0m 1s The patch has no lines that end in whitespace.
          +1 install 1m 33s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 1m 41s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 common tests 22m 21s Tests passed in hadoop-common.
              65m 20s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12733317/HADOOP-10971.004.patch
          Optional Tests javadoc javac unit findbugs checkstyle site
          git revision trunk / b0ad644
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6712/artifact/patchprocess/testrun_hadoop-common.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6712/testReport/
          Java 1.7.0_55
          uname Linux asf902.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6712/console

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          Thanks Kengo Seki for updating the patch. One comment:

          made -C to overrule -u, because timestamp isn't displayed when -C is specified

          I don't think -u should be no-op when -C is specified. -u is not only used for displaying modification time but also used for sorting outputs by modification time when -t is specified at the same time.

          sekikn Kengo Seki added a comment -

          Thanks Akira Ajisaka you are right. I'll fix it later.

          sekikn Kengo Seki added a comment -

          Fixed the problem.

          hadoopqa Hadoop QA added a comment -



          +1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 18m 34s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 2 new or modified test files.
          +1 javac 7m 28s There were no new javac warning messages.
          +1 javadoc 9m 37s There were no new javadoc warning messages.
          +1 release audit 0m 22s The applied patch does not increase the total number of release audit warnings.
          +1 site 2m 59s Site still builds.
          +1 checkstyle 1m 4s There were no new checkstyle issues.
          +1 whitespace 0m 1s The patch has no lines that end in whitespace.
          +1 install 1m 31s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 1m 38s The patch does not introduce any new Findbugs (version 2.0.3) warnings.
          +1 common tests 22m 25s Tests passed in hadoop-common.
              66m 14s  



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12733355/HADOOP-10971.005.patch
          Optional Tests javadoc javac unit findbugs checkstyle site
          git revision trunk / e453989
          hadoop-common test log https://builds.apache.org/job/PreCommit-HADOOP-Build/6718/artifact/patchprocess/testrun_hadoop-common.txt
          Test Results https://builds.apache.org/job/PreCommit-HADOOP-Build/6718/testReport/
          Java 1.7.0_55
          uname Linux asf906.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-HADOOP-Build/6718/console

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          Looks good to me, +1. I tried the command with some additional flags (-u, -R, -t, ...) and worked well. I'll commit it in May 19 if there are no additional comments. Thanks Kengo Seki.

          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk and branch-2. Thanks Kengo Seki for the contribution.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #7859 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7859/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #932 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/932/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk-Java8 #201 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/201/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2130 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2130/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #190 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/190/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Mapreduce-trunk-Java8 #200 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/200/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2148 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2148/)
          HADOOP-10971. Add -C flag to make `hadoop fs -ls` print filenames only. Contributed by Kengo Seki. (aajisaka: rev 3b50dcdce4ffe3d4e5892fca84909ff22be28739)

          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/shell/Ls.java
          • hadoop-common-project/hadoop-common/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/site/markdown/FileSystemShell.md
          • hadoop-common-project/hadoop-common/src/test/resources/testConf.xml
          • hadoop-common-project/hadoop-common/src/test/java/org/apache/hadoop/fs/shell/TestLs.java

            People

            • Assignee:
              sekikn Kengo Seki
              Reporter:
              rdub Ryan Williams
            • Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development