Uploaded image for project: 'Hadoop Common'
  1. Hadoop Common
  2. HADOOP-10441

Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed by Ganglia

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: 2.4.0
    • Component/s: metrics
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      The issue is reported by Dmytro Sen:

      Recently added Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed by Ganglia because its name contains "/"

      Proposal: Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" should be renamed to "rpc.RetryCache.NameNodeRetryCache.CacheHit"
      Here - org.apache.hadoop.ipc.metrics.RetryCacheMetrics#RetryCacheMetrics

        RetryCacheMetrics(RetryCache retryCache) {
          name = "RetryCache/"+ retryCache.getCacheName();
          registry = new MetricsRegistry(name);
          if (LOG.isDebugEnabled()) {
            LOG.debug("Initialized "+ registry);
          }
        }
      

        Attachments

        1. HADOOP-10441.000.patch
          0.8 kB
          Jing Zhao
        2. HADOOP-10441.000.patch
          2 kB
          Jing Zhao

          Activity

            People

            • Assignee:
              jingzhao Jing Zhao
              Reporter:
              jingzhao Jing Zhao
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: