Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-265

Support OSC 0 for changing SSH/telnet window title

    Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.9.13-incubating
    • Component/s: SSH, Telnet, Terminal
    • Labels:
      None

      Description

      The easiest way to test this is to manually change the window's title. For example, the following command works to change the window's title when using gnome-terminal:

      $ PROMPT_COMMAND='echo -ne "\033]0;SOME TITLE HERE\007"'
      $ 
      $ 
      

      When this same command is run through Guacamole, part of the new title is printed inline on every line (everything save for the first alphabetical character), and resembles artifacting:

      $ PROMPT_COMMAND='echo -ne "\033]0;SOME TITLE HERE\007"'
      OME TITLE HERE $ 
      OME TITLE HERE $ 
      

      ...NB: if you run this same command inside gnu screen, the output is slightly different (note the subsequent command prompts lack the same title artifacting)

      $ PROMPT_COMMAND='echo -ne "\033]0;SOME TITLE HERE\007"'
      OME TITLE HERE $ 
      $ 
      

      ...furthermore, if you detach and reattach to the same gnu screen, the artifacting is gone.

        Issue Links

          Activity

          mike.jumper Michael Jumper added a comment -

          OSC 0 as a means of setting the window title is part of the set of console codes supported by xterm (and tools which support those same codes, like the Gnome or MATE terminals). Guacamole's terminal emulator currently implements the same subset of console codes as the Linux console, not xterm.

          Adding such support would be nice, but this is not a bug.


            People

            • Assignee:
              mike.jumper Michael Jumper
              Reporter:
              Metuchen Mark Tomich
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development