Uploaded image for project: 'Guacamole'
  1. Guacamole
  2. GUACAMOLE-1076

Another copy of RemoteApp is launched in case of session reconnect

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: RDP
    • Labels:
      None

      Description

      Hi, I've performed a test deployment of Guacamole in my infra, most things are working as expected, thank you for this software.

      Unfortunately, I'm observing a strange behaviour with RemoteApps, which looks like a bug. If I disconnect from a RemoteApp session (for whatever reason), and then connect to it again, a new copy of application is launched, so after a couple of reconnects I could have 5+ launched applications in the same session. I've tried to limit an user to a single session, but that didn't help.

      Guacamole deployment: all deployed in docker containers on a single host per official install manual, no any configs changes

      Terminal services deployment: tried fully official deployment with AD per MS recommendations, and standalone test server with http://www.kimknight.net/remoteapptool, the result is the same

      Remote connection config: specified RDP, Hostname, Username, Password, checked "Ignore server certificate", and specified "RemoteApp" -> "Program", ||Notepad in my test case, all other options are the same.

      Steps to reproduce:

      1. Open a RemoteApp connection, check that application is successfully started
      2. Press Ctrl+Alt+Shift, select Disconnect from left side window menu on top
      3. Press Home button in "DISCONNECTED" window
      4. In Recent Connections select the same connection, and open it again
      5. After connecting to the session, observe that there are two application windows are present, please see the attached screenshots

      Could you please take a look on this issue, and fix it? If there are any logs or some other test steps are needed from my side, I'm happy to provide them

        Attachments

        1. before-reconnect.PNG
          37 kB
          Valerii
        2. after-reconnect.PNG
          27 kB
          Valerii

          Activity

            People

            • Assignee:
              mjumper Mike Jumper
              Reporter:
              Px Valerii
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: