Uploaded image for project: 'Groovy'
  1. Groovy
  2. GROOVY-8690

Bump picocli version to 3.2.0 from 3.1.0

    XMLWordPrintableJSON

    Details

    • Type: Dependency upgrade
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.0
    • Fix Version/s: 2.5.1
    • Labels:
      None

      Description

      Many improvements. For Groovy users, perhaps most interesting is better support for completion candidates (both bash completion scripts and JLine interactive applications). 

      The description for options and positional parameters can contain variables that expand to the default value or completion candidates.

      For more details, see https://github.com/remkop/picocli/releases/tag/v3.2.0

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rpopma Remko Popma
                Reporter:
                rpopma Remko Popma
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: