Uploaded image for project: 'Groovy'
  1. Groovy
  2. GROOVY-8670

Make groovy-bsf an optional "module" for 2.5.1+, i.e. not reference by groovy-all

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.0
    • Fix Version/s: 2.5.1
    • Component/s: None
    • Labels:

      Description

      The groovy-all dependency brings in all the common "modules" for Groovy. I don't think groovy-bsf is in common use any more. Plus the transitive bsf jar dependency isn't OSGi complaint which breaks* OSGi builds wanting to use the groovy-all dependency. Users needing bsf can simply add that dependency to their build.

       [*] Provides an annoying warning at least.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                paulk Paul King
                Reporter:
                paulk Paul King
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: