Uploaded image for project: 'Groovy'
  1. Groovy
  2. GROOVY-5593

groovy-all-2.0.0 does not work with JDK 1.5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.1
    • Component/s: None
    • Labels:
      None

      Description

      I assume this is not intended? The problem is that org.codehaus.groovy.jsr223.ScriptExtensions gets loaded, which uses JDK 1.6 classes. For example I get "java.lang.NoClassDefFoundError: javax/script/ScriptEngine". Seems like this makes groovy-all-2.0.0 unusable with JDK 1.5.

        Attachments

          Activity

            People

            • Assignee:
              melix Cédric Champeau
              Reporter:
              pniederw Peter Niederwieser
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: