I agree that we can make this more consistent. We should probably add the methods as you suggest:
but I am wondering whether we should take Groovy 2.0 as an opportunity to rename some of the existing methods:
consumeStreams instead of consumeProcessOutput and similarly waitForStreams or waitConsumingStreams instead of waitForProcessOutput. In which case I would remove "Process" from the name of the methods you are suggesting too. We would leave the old names around as aliases for a version or two.