Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 1.8.4
    • Fix Version/s: None
    • Component/s: None
    • Environment:
      Windows XP

      Description

      I installed Groovy-1.8.4 using the window installer. I then launched the Groovy Console and typed in groovy -version, groovy -v, and groovysh and each time I get an exception error. I have my JAVA_HOME variable set, I have my GROOVY_HOME variable set, but the console cannot move past this issue. I can execute Math(16).sqrt, and println commands, etc.

      Can someone tell me what to do to make sure that my installation of Groovy is working correctly? I am following "Progamming Groovy" book published by the Pragmatic Programmers.

      Thanks

        Activity

        serious created issue -
        John Wagenleitner added a comment -

        The Groovy Console (groovyConsole.bat) only understands Groovy syntax. The commands you referenced as a problem need to be run at the Windows command prompt.

        c:\Java\groovy-1.8.4>bin\groovy -version
        Groovy Version: 1.8.4 JVM: 1.6.0_27
        
        c:\Java\groovy-1.8.4>bin\groovy -v
        Groovy Version: 1.8.4 JVM: 1.6.0_27
        
        c:\Java\groovy-1.8.4>bin\groovysh
        Groovy Shell (1.8.4, JVM: 1.6.0_27)
        Type 'help' or '\h' for help.
        ------------------------------------------
        groovy:000> exit
        
        c:\Java\groovy-1.8.4>
        
        Pascal Schumacher added a comment -

        I guess this should be closed as "Not a Bug".

        Paul King added a comment -

        As per previous comments, if you can execute "Math(16).sqrt, and println etc" then your installation appears to be working. Using "groovy -v" etc. work from the commandline not the shell.

        Paul King made changes -
        Field Original Value New Value
        Assignee Paul King [ paulk ]
        Resolution Not A Bug [ 6 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Paul King made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
        Mark Thomas made changes -
        Workflow jira [ 12734052 ] Default workflow, editable Closed status [ 12745819 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
        Mark Thomas made changes -
        Workflow jira [ 12971541 ] Default workflow, editable Closed status [ 12979362 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        380d 15h 37m 1 Paul King 02/Dec/12 01:07
        Resolved Resolved Closed Closed
        5s 1 Paul King 02/Dec/12 01:07

          People

          • Assignee:
            Paul King
            Reporter:
            serious
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development