Groovy
  1. Groovy
  2. GROOVY-4981

Code examples on website are not visible

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The code snippets in the user guide, cookbook, and elsewhere on groovy.codehaus.org are not visible. Instead of a box containing something like:
      println 'Hello World'
      A small empty rectangle is displayed instead.
      It looks like this syntax highlighter library is being used: http://alexgorbatchev.com/SyntaxHighlighter/manual/installation.html. However, looking at the source of the page it appears that the javascript and css libraries that it uses aren't actually loaded, nor is the SyntaxHighlighter.all() JavaScript method invoked.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        488d 13h 26m 1 Guillaume Delcroix 21/Dec/12 09:46
        Mark Thomas made changes -
        Workflow jira [ 12971303 ] Default workflow, editable Closed status [ 12979089 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
        Mark Thomas made changes -
        Workflow jira [ 12733907 ] Default workflow, editable Closed status [ 12745575 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
        Guillaume Delcroix made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Assignee Guillaume Laforge [ guillaume ]
        Status Open [ 1 ] Closed [ 6 ]
        Pascal Schumacher added a comment - - edited

        As per previous comment this was caused by a firewall. The issue should be closed.

        George Belden added a comment -

        Yes I can confirm that the code samples are just being blocked by the firewall, as I'm home on the same laptop and now I can see them. I'm guessing the JavaScript is being blocked.

        I apologize for raising the concern.

        Paul King added a comment - - edited

        I definitely can't see them behind a corporate firewall of one of my customers when using IE. I suspect their IE configuration or firewall stops scripts loading from third-party sites. It seems to work from other browsers at that site though - so perhaps their IE config is the culprit.

        George Belden added a comment -

        This may actually be a firewall issue. I'll confirm this later today and post an update here. Thanks again.

        George Belden added a comment -

        John, thanks for the reply. I have JavaScript enabled on all my browsers, but still no luck seeing the samples. I'm currently on Windows 7.

        I can in fact see the samples from my android phone however.

        John Gibson added a comment -

        George, I can see the code samples, but I have to turn on Javascript. I'm using Firefox 3.6.23 and Firefox 7.

        George Belden added a comment -

        I can see the code samples on the home page, but I am still unable to see the code samples on the following pages for example:

        http://groovy.codehaus.org/Tutorial+1+-+Getting+started
        http://groovy.codehaus.org/Quick+Start

        All I see are empty boxes. I've tried with IE 8, Firefox 7, and Chrome 14.

        Paul King added a comment -

        The code samples are now back but without syntax highlighting - at least for the moment.

        Jochen Theodorou added a comment -

        Looks like a confluence problem. I filled HAUS-2113 for it

        John Gibson created issue -

          People

          • Assignee:
            Guillaume Delcroix
            Reporter:
            John Gibson
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development