Uploaded image for project: 'Groovy'
  1. Groovy
  2. GROOVY-4454

PATHEXT environment var overwritten in windows installer

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.7
    • Fix Version/s: 1.7.4
    • Component/s: windows installer
    • Labels:
      None
    • Environment:
      WinXP SP3

      Description

      After installing Groovy using groovy-1.5.7-installer.exe, I noticed problems to start my WebLogic server...
      After investigation it turned out it was no longer possible to run 'java' from command line, it did work when using 'java.exe'
      Some further investigation showed that the environment variable PATHEXT was now PATHEXT=;.groovy;.gy in stead of the usual value PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH

      Needless to say Groovy left the building in the mean time... (

        Attachments

          Activity

            People

            • Assignee:
              jbaumann Joachim Baumann
              Reporter:
              gjmathews1 jason mathews
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: