Groovy
  1. Groovy
  2. GROOVY-4034

Mixin's getClass() method replaces original getClass() implementation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.7
    • Fix Version/s: 1.6.9
    • Component/s: None
    • Labels:
      None

      Description

      class M {
          def doIt() {
              assert metaClass.owner.class == M // passes but shouldn't, should be T
          }
      }
      
      class T {}
      T.mixin(M)
      new T().doIt()
      

        Activity

        Luke Daley created issue -
        Roshan Dawrani added a comment - - edited

        This issue is not there on 1.7 onwards (http://groovyconsole.appspot.com/script/76002).

        How about upgrading to 1.7.x instead of getting it fixed on 1.6.9 and upgrading to that (assuming that you need the fix and can upgrade for that )?

        Roshan Dawrani added a comment -

        Guillaume / Jochen, does this issue look worth porting to 1.6.9?

        The issue is not there on 1.7.x and trunk.

        Guillaume Delcroix added a comment -

        Yes, you can port it to 1.6 too.
        I'm not yet 100% sure we'll do another 1.6.x, but till we don't do an 1.8, we should still port critical bug fixes to 1.6 at least.

        Roshan Dawrani made changes -
        Field Original Value New Value
        Assignee Roshan Dawrani [ roshandawrani ]
        Roshan Dawrani added a comment -

        Back-ported the fix.

        Roshan Dawrani made changes -
        Fix Version/s 1.6.9 [ 16236 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Guillaume Delcroix made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
        Mark Thomas made changes -
        Workflow jira [ 12732987 ] Default workflow, editable Closed status [ 12744775 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
        Mark Thomas made changes -
        Workflow jira [ 12970653 ] Default workflow, editable Closed status [ 12978460 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        28d 6h 44m 1 Roshan Dawrani 03/Mar/10 12:40
        Resolved Resolved Closed Closed
        104d 15h 9m 1 Guillaume Delcroix 16/Jun/10 04:50

          People

          • Assignee:
            Roshan Dawrani
            Reporter:
            Luke Daley
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development