Groovy
  1. Groovy
  2. GROOVY-3769

Groovy Console hangs if script is executed in rapid succession

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.7-beta-2
    • Fix Version/s: None
    • Component/s: Groovy Console
    • Labels:
      None
    • Environment:
      Mac OS 10.6.1
      Java 1.6.0_15

      Description

      Click the Run button as fast as you can (or press the shortcut), and soon the "Groovy executing" window will stay forever. Sometimes it's possible to interrupt the script or close the window, sometimes not. Seems to work with any script. For example:

      println "hi"
      

        Activity

        Peter Niederwieser created issue -
        Peter Niederwieser added a comment - - edited

        This also frequently happens when keeping the Groovy console open in the background. Once I switch back to the console, I suddenly get the "Groovy executing" dialog. To get rid of this dialog, I need to quit and restart the Groovy console.

        Pascal Schumacher added a comment -

        I could not reproduce this using Groovy 2.0.6 on Windows XP SP3.

        Even if I keep "Control-R" pressed the console responds after all executions are finished.

        Jochen Theodorou made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Assignee blackdrag blackdrag [ blackdrag ]
        Peter Niederwieser added a comment -

        Can't reproduce with latest Mac OS, Java, and Groovy. Definitely was a problem in September 2009.

        Paul King made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
        Mark Thomas made changes -
        Workflow jira [ 12732740 ] Default workflow, editable Closed status [ 12744478 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
        Mark Thomas made changes -
        Workflow jira [ 12970421 ] Default workflow, editable Closed status [ 12978212 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1201d 22h 29m 1 Jochen Theodorou 04/Jan/13 08:36
        Resolved Resolved Closed Closed
        8d 12h 3m 1 Paul King 12/Jan/13 20:40

          People

          • Assignee:
            Jochen Theodorou
            Reporter:
            Peter Niederwieser
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development