Groovy
  1. Groovy
  2. GROOVY-2019

Editable columns shuld default to no-editable for read only attributes

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The parent bug allowed for declaring arbitrary editing state to any property, even if the property is read-only. This task is to make the default editability be false if there is no setter in the appropriate property, and either ignore a true editability request or throw an error when it is explicitly set.

        Activity

        Danno Ferrin created issue -
        Danno Ferrin made changes -
        Field Original Value New Value
        Assignee Danno Ferrin [ shemnon ]
        Danno Ferrin made changes -
        Priority Major [ 3 ] Minor [ 4 ]
        Jochen Theodorou added a comment -

        Danno, can you give an example that makes it more reproducable for us?

        Jochen Theodorou added a comment -

        I am closing this issue for now, since Danno does currently not contribute and since nobody else seems to know what this issue is really about

        Jochen Theodorou made changes -
        Resolution Incomplete [ 4 ]
        Assignee Danno Ferrin [ shemnon ] blackdrag blackdrag [ blackdrag ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 3.0 [ 13489 ]
        Jochen Theodorou made changes -
        Parent GROOVY-2018 [ 54615 ]
        Issue Type Sub-task [ 7 ] Improvement [ 4 ]
        Paul King made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
        Mark Thomas made changes -
        Workflow jira [ 12731118 ] Default workflow, editable Closed status [ 12743065 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
        Mark Thomas made changes -
        Workflow jira [ 12969340 ] Default workflow, editable Closed status [ 12977096 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1806d 16h 47m 1 Jochen Theodorou 13/Jul/12 09:27
        Resolved Resolved Closed Closed
        13d 8h 22m 1 Paul King 26/Jul/12 17:49

          People

          • Assignee:
            Jochen Theodorou
            Reporter:
            Danno Ferrin
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development