Uploaded image for project: 'Groovy'
  1. Groovy
  2. GROOVY-1766

IncompatibleClassChangeError with static GString

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5
    • Component/s: None
    • Labels:
      None

      Description

      class Test {
      	static field = "Hello $who"
      }
      
      new Test()
      

      Of course it is not valid code but the error is atrocious

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              marc@anyware.co.uk Marc Palmer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: