Groovy
  1. Groovy
  2. GROOVY-1712

Source and test reorganization and Groovy core / gdk artifacts

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0-rc-3
    • Component/s: None
    • Labels:
      None

      Description

      The Groovy artifacts should be split in two:

      • a groovy-core.jar containing what's core to the language and the JDK (closures, default groovy methods, Swing builder, etc... with the addition of GroovyTestCase)
      • a groovy-gdk.jar containing all the library related stuff (JMX, etc)

      The groovy-core.jar should be "JarJar-ed" to embed ASM and Antlr.
      The ASM and Antlr classes embedded should be kept to a minimum (removing non-needed things like Antlr's python support and the likes)

      The sources and tests should be seperated accordingly in two different tree structures.
      No dependency from groovy-core on groovy-jdk, but groovy-jdk obviously depends on groovy-core

      Current tests should be put in some final10 folder (a better name might be appreciated) to keep all the tests as a regression testing process.
      New tests should have their own folder (package).
      And a dedicated package for TCK (language-related) tests should be created.

        Issue Links

        There are no Sub-Tasks for this issue.

          Activity

          Guillaume Delcroix created issue -
          Guillaume Delcroix made changes -
          Field Original Value New Value
          Link This issue depends upon GROOVY-1711 [ GROOVY-1711 ]
          Guillaume Delcroix made changes -
          Summary Source and test reorganization Source and test reorganization and Groovy core / gdk artifacts
          Description The Groovy artifacts should be split in two:

          - a groovy-core.jar containing what's core to the language and the JDK (closures, default groovy methods, Swing builder, etc... with the addition of GroovyTestCase)
          - a groovy-gdk.jar containing all the library related stuff (JMX, etc)

          The groovy-core.jar should be "JarJar-ed" to embed ASM and Antlr.
          The ASM and Antlr classes embedded should be kept to a minimum (removing non-needed things like Antlr's python support and the likes)
          The Groovy artifacts should be split in two:

          - a groovy-core.jar containing what's core to the language and the JDK (closures, default groovy methods, Swing builder, etc... with the addition of GroovyTestCase)
          - a groovy-gdk.jar containing all the library related stuff (JMX, etc)

          The groovy-core.jar should be "JarJar-ed" to embed ASM and Antlr.
          The ASM and Antlr classes embedded should be kept to a minimum (removing non-needed things like Antlr's python support and the likes)

          The sources and tests should be seperated accordingly in two different tree structures.
          No dependency from groovy-core on groovy-jdk, but groovy-jdk obviously depends on groovy-core
          Guillaume Delcroix made changes -
          Description The Groovy artifacts should be split in two:

          - a groovy-core.jar containing what's core to the language and the JDK (closures, default groovy methods, Swing builder, etc... with the addition of GroovyTestCase)
          - a groovy-gdk.jar containing all the library related stuff (JMX, etc)

          The groovy-core.jar should be "JarJar-ed" to embed ASM and Antlr.
          The ASM and Antlr classes embedded should be kept to a minimum (removing non-needed things like Antlr's python support and the likes)

          The sources and tests should be seperated accordingly in two different tree structures.
          No dependency from groovy-core on groovy-jdk, but groovy-jdk obviously depends on groovy-core
          The Groovy artifacts should be split in two:

          - a groovy-core.jar containing what's core to the language and the JDK (closures, default groovy methods, Swing builder, etc... with the addition of GroovyTestCase)
          - a groovy-gdk.jar containing all the library related stuff (JMX, etc)

          The groovy-core.jar should be "JarJar-ed" to embed ASM and Antlr.
          The ASM and Antlr classes embedded should be kept to a minimum (removing non-needed things like Antlr's python support and the likes)

          The sources and tests should be seperated accordingly in two different tree structures.
          No dependency from groovy-core on groovy-jdk, but groovy-jdk obviously depends on groovy-core

          Current tests should be put in some final10 folder (a better name might be appreciated) to keep all the tests as a regression testing process.
          New tests should have their own folder (package).
          And a dedicated package for TCK (language-related) tests should be created.
          Guillaume Delcroix made changes -
          Link This issue is depended upon by GROOVY-1713 [ GROOVY-1713 ]
          Guillaume Delcroix made changes -
          Assignee Russel Winder [ russel ]
          Guillaume Delcroix made changes -
          Fix Version/s 1.1-beta-2 [ 10436 ]
          Fix Version/s 1.1 [ 13166 ]
          Guillaume Delcroix made changes -
          Fix Version/s 1.1-beta-2 [ 10436 ]
          Fix Version/s 1.1 [ 13166 ]
          Guillaume Delcroix made changes -
          Fix Version/s 2.0 [ 13489 ]
          Fix Version/s 1.1 [ 13166 ]
          Russel Winder made changes -
          Assignee Russel Winder [ russel ]
          Guillaume Delcroix added a comment -

          Setting the fix to 1.8, as this related the modularity of Groovy 1.8.

          Guillaume Delcroix made changes -
          Fix Version/s 1.8-beta-x [ 15750 ]
          Fix Version/s 2.0 [ 13489 ]
          Guillaume Delcroix added a comment -

          More information on modularization of Groovy 1.8:
          http://docs.codehaus.org/display/GROOVY/Groovy+1.8+modularization

          Hans Dokter is also helping us on a Gradle build for Groovy 1.8 which will enable us to move forward and make Groovy more modular.

          Guillaume Delcroix made changes -
          Link This issue is depended upon by GROOVY-4157 [ GROOVY-4157 ]
          Guillaume Delcroix made changes -
          Link This issue depends upon GROOVY-4160 [ GROOVY-4160 ]
          Paul King made changes -
          Fix Version/s 2.0-beta-x [ 17013 ]
          Fix Version/s 1.8.x [ 15750 ]
          Jochen Theodorou added a comment -

          I close this one as fixed, because in RC2 we had the first version of Groovy in which we have modules realized

          Jochen Theodorou made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 2.0-beta-x [ 17013 ]
          Fix Version/s 2.0-rc-3 [ 18556 ]
          Resolution Fixed [ 1 ]
          Assignee blackdrag blackdrag [ blackdrag ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 13:32:57 UTC 2015 [ 1428240777691 ]
          Mark Thomas made changes -
          Workflow jira [ 12730836 ] Default workflow, editable Closed status [ 12742768 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 02:11:23 UTC 2015 [ 1428286283443 ]
          Mark Thomas made changes -
          Workflow jira [ 12972454 ] Default workflow, editable Closed status [ 12980281 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1941d 23h 53m 1 Jochen Theodorou 08/Jun/12 09:29

            People

            • Assignee:
              Jochen Theodorou
              Reporter:
              Guillaume Delcroix
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development