Uploaded image for project: 'Apache Gora'
  1. Apache Gora
  2. GORA-304

I can't integrade my hbase-0.98~hadoop-2.2.0 cluster into nutch 2.2.1 which used apache-gora-0.3

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 0.3
    • Fix Version/s: 0.3
    • Component/s: gora-hbase
    • Labels:
    • Environment:
      hbase-0.98 hadoop-2.2.0 nutch-2.2.1 Gora0.3

      Description

      InjectorJob: starting at 2014-03-18 04:35:43
      InjectorJob: Injecting urlDir: urls/seed.txt
      InjectorJob: org.apache.gora.util.GoraException: java.lang.RuntimeException: java.lang.NumberFormatException: For input string: "60000s���&c�@PBUF
      
      localhost�����("
      at org.apache.gora.store.DataStoreFactory.createDataStore(DataStoreFactory.java:167)
      at org.apache.gora.store.DataStoreFactory.createDataStore(DataStoreFactory.java:135)
      at org.apache.nutch.storage.StorageUtils.createWebStore(StorageUtils.java:75)
      at org.apache.nutch.crawl.InjectorJob.run(InjectorJob.java:221)
      at org.apache.nutch.crawl.InjectorJob.inject(InjectorJob.java:251)
      at org.apache.nutch.crawl.InjectorJob.run(InjectorJob.java:273)
      at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
      at org.apache.nutch.crawl.InjectorJob.main(InjectorJob.java:282)
      Caused by: java.lang.RuntimeException: java.lang.NumberFormatException: For input string: "60000s���&c�@PBUF
      
      localhost�����("
      at org.apache.gora.hbase.store.HBaseStore.initialize(HBaseStore.java:127)
      at org.apache.gora.store.DataStoreFactory.initializeDataStore(DataStoreFactory.java:102)
      at org.apache.gora.store.DataStoreFactory.createDataStore(DataStoreFactory.java:161)
      ... 7 more
      Caused by: java.lang.NumberFormatException: For input string: "60000s���&c�@PBUF
      
      localhost�����("
      at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
      at java.lang.Integer.parseInt(Integer.java:492)
      at java.lang.Integer.parseInt(Integer.java:527)
      at org.apache.hadoop.hbase.HServerAddress.<init>(HServerAddress.java:63)
      at org.apache.hadoop.hbase.MasterAddressTracker.getMasterAddress(MasterAddressTracker.java:63)
      at org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.getMaster(HConnectionManager.java:354)
      at org.apache.hadoop.hbase.client.HBaseAdmin.<init>(HBaseAdmin.java:94)
      at org.apache.gora.hbase.store.HBaseStore.initialize(HBaseStore.java:109)
      ... 9 more

        Activity

        Hide
        kongxianghe1234 kongxianghe added a comment -

        I have followed the steps from this book named Web Crawling and Data Mining with Apache Nutch - Laliwala, Zakir.pdf

        Show
        kongxianghe1234 kongxianghe added a comment - I have followed the steps from this book named Web Crawling and Data Mining with Apache Nutch - Laliwala, Zakir.pdf
        Hide
        talat Talat UYARER added a comment -

        kongxianghe,

        Gora 0.3 support 0.90.x family. In Gora 0.4 We will support Hbase 0.94.x family. To sum up Gora doesnt support Hbase 0.98 yet. Please try with 0.90.x.

        Show
        talat Talat UYARER added a comment - kongxianghe , Gora 0.3 support 0.90.x family. In Gora 0.4 We will support Hbase 0.94.x family. To sum up Gora doesnt support Hbase 0.98 yet. Please try with 0.90.x.
        Hide
        talat Talat UYARER added a comment -

        This is not a bug.

        Show
        talat Talat UYARER added a comment - This is not a bug.
        Hide
        kongxianghe1234 kongxianghe added a comment -

        you mean that nutch-2.2.1 can't integrate hbase-0.98 ? you know i have
        established a cluster based on hadoop-2.2.0 and hbase-0.98 ,hbase-0.94.x can't support hadoop-2.2.0 which is a stable version of hadoop. Please release a stable version of Gora to support hbase higher version ,please!

        Show
        kongxianghe1234 kongxianghe added a comment - you mean that nutch-2.2.1 can't integrate hbase-0.98 ? you know i have established a cluster based on hadoop-2.2.0 and hbase-0.98 ,hbase-0.94.x can't support hadoop-2.2.0 which is a stable version of hadoop. Please release a stable version of Gora to support hbase higher version ,please!
        Hide
        talat Talat UYARER added a comment -

        Yes kongxianghe. At the peresent Nutch cant integrate lastest Hbase version and Hadoop. AFAIK Gora community can be those version support after 0.5 release. But I should say I am not an authority. If you want to use hadoop 2.x you can use with nutch 1.x. If you have questions, please send nutch user list.

        Show
        talat Talat UYARER added a comment - Yes kongxianghe . At the peresent Nutch cant integrate lastest Hbase version and Hadoop. AFAIK Gora community can be those version support after 0.5 release. But I should say I am not an authority. If you want to use hadoop 2.x you can use with nutch 1.x. If you have questions, please send nutch user list.

          People

          • Assignee:
            Unassigned
            Reporter:
            kongxianghe1234 kongxianghe
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 12h
              12h
              Remaining:
              Remaining Estimate - 12h
              12h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development