Giraph
  1. Giraph
  2. GIRAPH-8

Update references to Yahoo bug that needs to be fixed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      In BspServiceMaster.java there are three TODOS (lines 1342, 1348, 1377) referring to those sections of code being deleted after Bug#4340282 is fixed. We should either verify that this has been fixed, change the comments to a more descriptive explanation, or fix whatever bug is being referenced.

        Activity

        Avery Ching added a comment -

        This has to do with internal Yahoo! bugs that need to be ported to JIRA. I will do this. The bug has not been fixed and the issue is that basically we can only store so many VertexRange objects in a single ZooKeeper znode. Currently there should be a workaround to prevent too many vertex ranges from being created.

        Harsh J added a comment -

        Jakob,

        I think this can be resolved as invalid/etc. as it seems to have gotten fixed over time. The TODOs no longer exist in this class, and the ones that do exist in the graph package itself, do not carry ill references to anything from Yahoo's internal issues.


          People

          • Assignee:
            Unassigned
            Reporter:
            Jakob Homan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development