Giraph
  1. Giraph
  2. GIRAPH-183

Add Claudio's FOSDEM presentation (slides and video) to the site

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0.0
    • Component/s: site
    • Labels:
    1. GIRAPH-183.diff
      1.0 kB
      Claudio Martella

      Issue Links

        Activity

        Claudio Martella added a comment -

        Site update.

        Avery Ching added a comment -

        +1. This is great stuff Claudio.

        Hudson added a comment -

        Integrated in Giraph-trunk-Commit #102 (See https://builds.apache.org/job/Giraph-trunk-Commit/102/)
        GIRAPH-183: Add Claudio's FOSDEM presentation (slides and video) to the site (Revision 1325822)

        Result = SUCCESS
        claudio : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1325822
        Files :

        • /incubator/giraph/trunk/CHANGELOG
        • /incubator/giraph/trunk/src/site/xdoc/index.xml
        Claudio Martella added a comment -

        It's actually quite weird, mvn site:site fails due to some missing symbols from hadoop secure...

        Ken Nakagama added a comment -

        Its a great slide deck Claudio

        Avery Ching added a comment -

        Are the problems related to GIRAPH-168?

        Claudio Martella added a comment -

        To be honest I don't have a clue. The issue is just with site:site, it does compile, package and install otherwise. I tried specifying the hadoop_non_secure profile, but still the same problem.

        Eugene Koontz added a comment -

        GIRAPH-168 is definitely related. I get the same kind of errors with "mvn compiler:compile", which is being invoked by "mvn site:site":

        [ec2-user@ip-10-161-115-188 giraph]$ mvn clean compiler:compile
        [INFO] Scanning for projects...
        [INFO]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building Apache Incubator Giraph 0.2-SNAPSHOT
        [INFO] ------------------------------------------------------------------------
        [INFO]
        [INFO] --- maven-clean-plugin:2.4.1:clean (default-clean) @ giraph ---
        [INFO] Deleting /home/ec2-user/giraph/target
        [INFO]
        [INFO] --- maven-compiler-plugin:2.3.2:compile (default-cli) @ giraph ---
        [INFO] Compiling 142 source files to /home/ec2-user/giraph/target/classes
        [INFO] -------------------------------------------------------------
        [ERROR] COMPILATION ERROR :
        [INFO] -------------------------------------------------------------
        [ERROR] /home/ec2-user/giraph/src/main/java/org/apache/giraph/comm/BasicRPCCommunications.java:[66,28] can\
        not find symbol
        symbol  : class ProtocolSignature
        location: package org.apache.hadoop.ipc
        
        Eugene Koontz added a comment -

        Currently mvn compiler:compile is not working due to a failure to use munge directives for the default profile.

        Eugene Koontz added a comment -

        Requested help for this on the maven mailing list: http://www.mail-archive.com/users@maven.apache.org/msg124398.html

        Claudio Martella added a comment -

        Ok, thanks for looking into this Eugene.

        Eugene Koontz added a comment -

        I found that mvn clean compile site works on trunk (you may also shorten build time with: mvn -DskipTests clean compile site).

        The key is that the 'compile' phase prevents the default 'compiler:compile' ('compiler' plugin and 'compile' goal) from executing.

        mvn -PX clean compile site also works for X in {{

        {hadoop_trunk, hadoop_facebook*, hadoop_0.23, hadoop_1.0, hadoop_0.20.203, hadoop_non_secure}

        }}.

        *with -Dhadoop.jar.path=$HOME/hadoop-20/build/hadoop-0.20.1-dev-core.jar

        I think it would be good to get 'mvn site' working on its own, though, which will work if we can get maven to always run the 'compile' phase prior to the 'site' phase, whenever a user runs 'mvn site'.

        Claudio Martella added a comment -

        OK, great, I'll test that. Just one minor thing. We shouldn't use -DskipTests because it creates a site stating no test coverage.

        Eugene Koontz added a comment -

        That's a good point, Claudio, thanks.


          People

          • Assignee:
            Claudio Martella
            Reporter:
            Claudio Martella
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development