Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0_M1
    • Fix Version/s: 3.0
    • Component/s: eclipse-plugin
    • Labels:
      None

      Description

      When OSGi application project doesn't contain OSGi bundle, or specified contained bundle can not be resolved at deployment time, more user friendly message which clearly points out the problem would be more nice that throw the DeploymentException.

      1. ASF.LICENSE.NOT.GRANTED--screenshot-1.jpg
        362 kB
        Han Hong Fang
      2. moreFriendlyMessage_735.patch
        2 kB
        Yi Xiao
      3. screenshot-with-patch.JPG
        142 kB
        Han Hong Fang

        Activity

        Han Hong Fang added a comment -

        The current message at deployment failure.

        Yi Xiao added a comment -

        Now, if the EBA could not deploy to the server, the unsatisfactory bundle infos will be report to the user.

        Han Hong Fang added a comment -

        Just tried the patch, and two comments:
        1. The solution closely depends on the message format of getDeploymentStatus().getMessage(). It extracts the first caused by statement, and the display info on dialog is exactly the same info from the message (same content and same format controlled by "\n").
        2. In "(&(symbolicname=TestBundle1)(version>=1.0.0))", symbol "&" disappears in dialog content (by checking the details section, "&" shows there.).

        I don't figure out a better solution so far, but I believe there will be one.

        Han Hong Fang added a comment -

        Attached the screenshot after applying patch.

        Jarek Gawor added a comment -

        I think for this we need to look at the underlying error generated by the Aries application code and/or Felix OBR itself.

        Jarek Gawor added a comment -

        In ARIES-734 I back ported some changes in the Aries application resolver to throw much more nicer and human readable error messages. I also updated Geronimo trunk to use to pick up the updated Aries code in revision 1160973.
        I believe these changes should address this problem. If not please re-open.


          People

          • Assignee:
            Jarek Gawor
            Reporter:
            Han Hong Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development