Uploaded image for project: 'Geronimo-Devtools'
  1. Geronimo-Devtools
  2. GERONIMODEVTOOLS-465

The 'Eclipse-LazyStart' header is deprecated, use 'Bundle-ActivationPolicy'

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.1.3
    • Component/s: eclipse-plugin
    • Labels:
      None

      Description

      MANIFEST.MF from org.apache.geronimo.st.core plugin (and possibly others) uses Eclipse-LazyStart which is deprecated and OSGi's 'Bundle-ActivationPolicy' is recommended.

        Attachments

        1. GERONIMODEVTOOLS-465.patch
          5 kB
          Barrett Jay Reed

          Activity

            People

            • Assignee:
              mcconne Tim McConnell
              Reporter:
              jlaskowski Jacek Laskowski
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: