Uploaded image for project: 'Geronimo'
  1. Geronimo
  2. GERONIMO-732

Change Geronimo Build to use correct version of Tomcat AJP JAR

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0-M4
    • Component/s: Tomcat
    • Labels:
      None

      Description

      Geronimo should be changed to use the tomcat-ajp-5.5.9.jar jar that matches the Tomcat version we are using. In the past we have been using the tomcat-jk2-5.0.18.jar. Also according to the Jakarta Tomcat Connectors page JK2 is officially
      unsupported and has been put in maintainer mode and no further development
      will take place
      http://jakarta.apache.org/tomcat/connectors-doc/news/20041100.html#20041115.1

      We need to:

      • Change the geronimo build to use this differently named and versioned file
      • change the tomcat_jk2_version property in project.properties to be tomcat_ajp_version so that no one on the future thinks we are using the unsupported JK 2.

        Attachments

          Activity

            People

            • Assignee:
              johnrsisson John Sisson
              Reporter:
              johnrsisson John Sisson
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: