Uploaded image for project: 'Geronimo'
  1. Geronimo
  2. GERONIMO-6747

.jsp cannot be compiled to .class

    XMLWordPrintableJSON

    Details

    • Type: Test
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.8
    • Fix Version/s: 2.1.8
    • Component/s: JVM-compatibility, Tomcat
    • Security Level: public (Regular issues)
    • Labels:
      None

      Description

      The project has been released (installed to the computer), the previous environment is: Geronimo 2.1.8 (embedded tomcat6.35) + java7. Now you need to upgrade java7 to java11, when you first visit the web page, you get an error:
      Jsp Servlet.service () threw an exception, "Cannot compile JSP class:
      An error occurred at line: 1 in the generated java file
      The type java.io.ObjectInputStream cannot be resolved. It is indirectly referenced from required .class files.
      Trying to replace Jasper.jar, but the service started up error

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mengln mengln
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: