Geronimo
  1. Geronimo
  2. GERONIMO-6290

Add explicit import-packages for some module builders

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 3.0-beta-1
    • Fix Version/s: 3.0-beta-2, 3.0.2
    • Component/s: deployment
    • Security Level: public (Regular issues)
    • Labels:
      None

      Description

      Sometimes, while users include some spec API classes in their applications, it will cause some CCE. Considering that, it is always required to use those api classes from server runtime if the application will take advantage of those features from server, it is better to add those packages explicitly in the defaultEnvironment.

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Ivan
            Reporter:
            Ivan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development