Geronimo
  1. Geronimo
  2. GERONIMO-5873

starttls.required is not supported by JavaMail

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.7, 2.2.1, 3.0.0
    • Fix Version/s: None
    • Component/s: mail
    • Security Level: public (Regular issues)
    • Labels:
      None

      Description

      starttls.required is not currently supported by our javamail implementation, but it looks like it should be.

      if starttls.enable is set to true, then we will require that the server support TLS. This appears to be incorrect. We should only require TLS, if starttls.required=true.

        Issue Links

          Activity

          Hide
          Hendrik Saly added a comment -

          Resolved with rev 1641706

          Show
          Hendrik Saly added a comment - Resolved with rev 1641706

            People

            • Assignee:
              Hendrik Saly
              Reporter:
              Kevan Miller
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development