Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0-M1
    • Component/s: Tomcat
    • Security Level: public (Regular issues)
    • Labels:
      None

      Description

      In the latest Tomcat 7, some new features about cookie version 1 is are added, while setting strict_servlet_complliance, it would use cookie version 1. From my testing, it would broke the IE, it always rejects the cookie values as double quote is used to wrap the values. But firefox works well ...

        Activity

        Rick McGuire made changes -
        Fix Version/s 3.0-M1 [ 12315090 ]
        Fix Version/s 3.0 [ 12314206 ]
        Ivan made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Ivan added a comment -

        I commit some changes to trunk At revision: 944957. Now we would always use cookie version 0.
        Please figure out if I miss anything !

        Show
        Ivan added a comment - I commit some changes to trunk At revision: 944957. Now we would always use cookie version 0. Please figure out if I miss anything !
        Ivan created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Ivan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development