Uploaded image for project: 'Geronimo'
  1. Geronimo
  2. GERONIMO-5246

Geronimo 3.0 version of activemq still has spring dependencies.

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0-M1
    • Component/s: ActiveMQ
    • Security Level: public (Regular issues)
    • Labels:
      None

      Description

      The geronimo-activemq plugin still contains dependencies on a number of springframework components, and there is code that will not compile cleanly if these dependencies are removed. The main problem classes are BrokerServiceGBeanImpl and GeronmoPropertyPlaceholderConfigurer. The compilation failure of these classes causes problems with a couple of other classes.

        Attachments

          Activity

            People

            • Assignee:
              gawor@mcs.anl.gov Jarek Gawor
              Reporter:
              rickmcguire Richard McGuire
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: