Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Component/s: osgi
    • Security Level: public (Regular issues)
    • Labels:
      None

      Description

      Since Geronimo 3.0 could only run 1.6+, I think we do not need to keep those spec APIs and impl which are shipped by JRE, including JAXB API, JAXB Impl, JAXWS, etc.

      1. GERONIMO-4970-1.patch
        14 kB
        Shiny Cheng
      2. GERONIMO-4970-2.patch
        10 kB
        Shiny Cheng

        Activity

        Hide
        Ivan added a comment -

        This should be done

        Show
        Ivan added a comment - This should be done
        Hide
        Shiny Cheng added a comment -

        This time it's about removing saaj 1.3 from dependencies.

        Show
        Shiny Cheng added a comment - This time it's about removing saaj 1.3 from dependencies.
        Hide
        Rick McGuire added a comment -

        The ws-metadata patch was committed in revision r890833. Thanks Shiny.

        Show
        Rick McGuire added a comment - The ws-metadata patch was committed in revision r890833. Thanks Shiny.
        Hide
        Shiny Cheng added a comment -

        It's about removing geronimo-ws-metadata_2.0_spec from dependencies.

        Show
        Shiny Cheng added a comment - It's about removing geronimo-ws-metadata_2.0_spec from dependencies.

          People

          • Assignee:
            Unassigned
            Reporter:
            Ivan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development