Geronimo
  1. Geronimo
  2. GERONIMO-4486

Custom server assembly portlet doesn't filter specific word

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: general
    • Security Level: public (Regular issues)
    • Labels:
      None
    • Environment:
      • IBM SDK 1.6
      • Windows XP SP2 English

      Description

      In Custom server assebmly portlet, the function "Filter by category and name" seems stop working when I type "console", but it works well on other words like "tomcat", "dojo", etc. I test in both IE 7 and firefox 3.0.4.

        Activity

        Han Hong Fang created issue -
        Donald Woods made changes -
        Field Original Value New Value
        Priority Major [ 3 ] Critical [ 2 ]
        Fix Version/s 2.2 [ 12312965 ]
        Hide
        Lin Sun added a comment -

        mark as regression as this worked before.

        Show
        Lin Sun added a comment - mark as regression as this worked before.
        Lin Sun made changes -
        Regression [Regression]
        Hide
        Lin Sun added a comment -

        sorry marked the wrong jira earlier. The reason that you cannot filter console correctly is because the word console resides within the hyperlinks (all these hyperlinks contain ../console/..). I'll try to work around this. Thanks.

        Show
        Lin Sun added a comment - sorry marked the wrong jira earlier. The reason that you cannot filter console correctly is because the word console resides within the hyperlinks (all these hyperlinks contain ../console/..). I'll try to work around this. Thanks.
        Lin Sun made changes -
        Regression [Regression]
        Lin Sun made changes -
        Assignee Lin Sun [ linsun ]
        Hide
        Lin Sun added a comment -

        fixed in rev 732039. You should see console filtered correctly now, by seeing only the plugins whose names/ desp or categories contain word "console". Many thanks for reporting this!

        Lin

        Show
        Lin Sun added a comment - fixed in rev 732039. You should see console filtered correctly now, by seeing only the plugins whose names/ desp or categories contain word "console". Many thanks for reporting this! Lin
        Lin Sun made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Hide
        Han Hong Fang added a comment -

        Filter still doesn't work on "console", but works well on "ejb", "tomcat" etc. Verified in build 20090106 both tomcat and jetty.

        Show
        Han Hong Fang added a comment - Filter still doesn't work on "console", but works well on "ejb", "tomcat" etc. Verified in build 20090106 both tomcat and jetty.
        Hide
        Lin Sun added a comment -

        There are quite a few builds yesterday and I don't think the change (rev 732029) went into the build you used. Can you please try a today's build (1/7)? Thanks

        Lin

        Show
        Lin Sun added a comment - There are quite a few builds yesterday and I don't think the change (rev 732029) went into the build you used. Can you please try a today's build (1/7)? Thanks Lin
        Hide
        Han Hong Fang added a comment -

        Verified again in build 20090107_1500, filter works well on other words but failed on "console".

        Janet

        Show
        Han Hong Fang added a comment - Verified again in build 20090107_1500, filter works well on other words but failed on "console". Janet
        Hide
        Lin Sun added a comment -

        Hi Janet, what browser/OS are you using? I assume you didn't use double quotes around console, right?

        Thanks

        Lin

        Show
        Lin Sun added a comment - Hi Janet, what browser/OS are you using? I assume you didn't use double quotes around console, right? Thanks Lin
        Hide
        Lin Sun added a comment -

        verified word console works fine on my safari and firefox 2 on my macbook pro with a today's build. Please provide the browser and OS you used. Thanks.

        Show
        Lin Sun added a comment - verified word console works fine on my safari and firefox 2 on my macbook pro with a today's build. Please provide the browser and OS you used. Thanks.
        Hide
        Han Hong Fang added a comment -

        Interesting... So I suspect the problem is browser/local related. I design following cases to find the really problem.

        Installed Geronimo build 20090107_1500 on Windows XP SP2 English, and then

        To access admin console from a machine, whose local is English:

        1. In IE7 or IE6 – console doesn't work, but others are OK.
        2. In firefox 3.0.5 – all words work well.

        To access admin console from a machine, whose local is China (admin console shows Chinese). In this case, no mater in firefox 3.0.5 or IE 7, filter failed on ALL words.

        BTW, when typing keyword into filter, I didn't use quotes.

        Janet

        Show
        Han Hong Fang added a comment - Interesting... So I suspect the problem is browser/local related. I design following cases to find the really problem. Installed Geronimo build 20090107_1500 on Windows XP SP2 English, and then To access admin console from a machine, whose local is English: 1. In IE7 or IE6 – console doesn't work, but others are OK. 2. In firefox 3.0.5 – all words work well. To access admin console from a machine, whose local is China (admin console shows Chinese). In this case, no mater in firefox 3.0.5 or IE 7, filter failed on ALL words. BTW, when typing keyword into filter, I didn't use quotes. Janet
        Hide
        Han Hong Fang added a comment - - edited

        Hi Lin,

        I notice that when admin console shows Chinese, the section "Plugin Groups in local server" disappears. So I guess that the filter failure in Chinese local may caused by the localization.

        Could you help to investigate? If necessary, I can open another JIRA for the problem in Chinese local, and only keep this JIRA only for the problem in IE with English local.

        Janet

        Show
        Han Hong Fang added a comment - - edited Hi Lin, I notice that when admin console shows Chinese, the section "Plugin Groups in local server" disappears. So I guess that the filter failure in Chinese local may caused by the localization. Could you help to investigate? If necessary, I can open another JIRA for the problem in Chinese local, and only keep this JIRA only for the problem in IE with English local. Janet
        Hide
        Lin Sun added a comment -

        Hi Janet, thanks for the feedback! Interesting, doesn't work with IE. This may just be a limitation as I don't know if we'll be able fix that in time for 2.2.

        Regarding the other prob related to Chinese admin console, yes please open a new jira on that. However, I dont have such an env. Maybe you could look into submitting a patch?

        Thanks

        Lin

        Show
        Lin Sun added a comment - Hi Janet, thanks for the feedback! Interesting, doesn't work with IE. This may just be a limitation as I don't know if we'll be able fix that in time for 2.2. Regarding the other prob related to Chinese admin console, yes please open a new jira on that. However, I dont have such an env. Maybe you could look into submitting a patch? Thanks Lin
        Hide
        Han Hong Fang added a comment -

        Hi Lin,

        Verified in build 20090111, the problems in Chinese admin console described above are already fixed by Jeff.

        Show
        Han Hong Fang added a comment - Hi Lin, Verified in build 20090111, the problems in Chinese admin console described above are already fixed by Jeff.
        Donald Woods made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Lin Sun
            Reporter:
            Han Hong Fang
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development