Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-8546

Colocated regions missing some buckets after restart

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: In Progress
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 1.11.0, 1.12.0, 1.13.0
    • Fix Version/s: None
    • Component/s: regions

      Description

      After restart all servers at the same time, some colocation regions missing some buckets.

      This issue exist for a long time and become visible from 1.11.0 by introducing this changes GEODE-7042 .

      How to reproduce the issue:

      1.  Start two locators and two servers
      2.  Create PARTITION_REDUNDANT_PERSISTENT region with redundant-copies=1
      3.  Create few PARTITION_REDUNDANT regions(I used six regions) colocated with persistent region and redundant-copies=1
      4.  Put some entries.
      5.  Restart servers(you can simply run "kill -15 <server_pids>" and then from two terminals start both of them at the same time)
      6.  It will take a time to get server startup finished and for the latest region bucketCount will be lower than expected on one member

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mkevo Mario Kevo
                Reporter:
                mkevo Mario Kevo
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: