Uploaded image for project: 'Geode'
  1. Geode
  2. GEODE-8331

allow GFSH to connect to newer and older locator/server

    XMLWordPrintableJSON

    Details

      Description

      When using an older or newer gfsh to connect to an older or newer distributed system gfsh will throw a warning error and not connect.
      Example warning message Cannot use a 9.8.5 gfsh client to connect to a 9.9.0 cluster..

      The desired behavior is to allow gfsh connect and only if there is an issue with an updated /unknown command parsing should the system throw an error and provide the extra guidance of what version the servers are at and the version of the current gfsh cli.

      Initially add these capability into the newer product version
      Later based on the feasibility of adding this to older version, this will be ported into the older version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jinmeiliao Jinmei Liao
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: